WD ShareSpace adding more drives

I have a WD ShareSpace currently with the factory 2 x 1TB hard drives  running in mirroring mode.

I would like to upgrade to 4 x 2TB hard drives.

How do I go about this?

Do I simply take out the current 2 hard drives and replace with the 4 new ones?

I have read conflicting posts

  1. The OS is on the hard drives?

  2. That the OS will just copy from the device onto the new hard drive when installed?


The Operating System of the WD ShareSpace is indeed stored within the disk drives. This means that replacing all disks at once will render the device unusable. The best method would be to add 3 new drives will keeping 1 original drive, then rebuilding the RAID volume in order to allow for the Operating System to copy. This may result in a degraded volume as the original drive will be smaller in capacity, so the RAID may not properly align.

After this, then replacing the last disk is what follows, then a full factory reset and a full RAID rebuild in order to create a new, clean volume. Please note this process will erase all data currently stored, but will allow for the unit to operate under optimal conditions.

1 Like

Thank you so much. Just the answer I was looking for.

Can you recomend any current model WD 2TB drives that would be compatible with the ShareSapce?

I know you should use all the same drives.

Any help with compatible hard drives would be great.

The 2 current models are

WD20EZRX SATA 6 Gb/s 3.5 Inch IntelliPower 2 TB 64 MB
WD20EARX SATA 6 Gb/s 3.5 Inch IntelliPower 2 TB

64 MB

Can anyone tell me if these drives will work in my ShareSapce ?


From the WD Green family of disk drives, family members EACS, EADS, and EARS would be the best possible matches for the WD ShareSpace based on controller generations.

Thanks for the reply.

As these 3 models have been discontinued and I cant find any, would the newer models still work? What problems could they have?

I certainly dont want to have to retire my ShareSpace.

Just a follow up of what worked for me.

Tried the above recommendation but it did not work.

Removed one original HD and placed 3 new HD’s in and let rebuild raid 01 mirror.

Swapped out last remaining HD with 4th new HD

Reset to factory defaults but the unit became unresponsive. All green HD lights but no power light and could not connect through browser or detect using WD Discovery or WD Link.

Replaced original 2 HD’s and removed all new ones. The raid rebuilt and all was back to normal and could log in.

Here is what worked.

Left in 2 original 1TB HD’s and added 2 new 2TB HD’s

Built Raid 01 mirror and ended up with a 2TB raid mirror (the SharSpace was always going to use smallest HD size)

Removed another 1Tb HD and turned unit on, logged in and all HD’s showed Good.

Removed 2nd old 1TB HD and replaced with last new 2TB HD

Same problem as before so replaced last old HD again and could log in again.

Built a raid 01 (2 mirror mode)

Turned unit on and could log on.

Removed last 1TB HD and replaced with last 2TB HD ( now a total of 4x2TB HD’s)

Turned unit on and  was  showing all HD’s as Good.

I clicked the option to clean all drives under WD Storage Manager. (may have only given me the option to clean 3 HD’s I think)

Built a raid 10

All Good.


Also I when I ordered the EARS HD’s the supplier upgraded them to the new EZRX drives as they had none.

So I can confirm that the newer EZRX HD’s work…so far.