WD Setup Problems

Hello people from the WD Community. :slight_smile:

I have been using WD products for quite some time and my OS was XP. So basically everything was fine. Now i upraded my machine and the OS is Windows 7. I connected my external WD Home Edition 1TB and double clicked the setup file to install the necessary software for WD to work correctly. So the window of the installation pops up like it should and the funny thing is that you have to agree to the licence agreement to proceed. There are these two buttons , usually “accept” and “decline”. But this time the buttons were without NAMES!!! I remembered that the left one is the “accept” button , so i clicked it and the next window showed available stuff to install with out any names too! I closed the window because i don’t know which are the ones i need.

So basically my question is , what is it? I mean , is this something about Windows 7? Maybe the setup file was meant for Vista and older Microsoft products? Is there a way to get a newer one? It’s funny because i can’t properly turn off my hard drive because the turn off button only works with the software. Please help me out. :frowning:

Verify that you have installed the Following applications on your Computer :

1- JAVA

2- Flash Player

3-OS ( Windows 7 ) Language is English

Still the Same ?

Then You Can Download  the Softwares Directly From Western Digital Website Which are Gonna Work at 100% Click the link below to go to the Downloads Section :

http://support.wdc.com/product/download.asp?groupid=111&lang=en


Click the Kudos star to say thank you for helpful posts. And be sure to come back to click the ‘Accept as Solution’ button for the post that solved your issue. This may help someone else.

2 Likes

Thank you Gabthemonster. :) I installed the new WD Drive Manager and now everything works just like it should. :slight_smile:

Ohh…wait. Now the drive is acting really weird. :frowning: Like when i copy something from the external to my internal , usually it works fine , but sometimes it just stops. Sometimes it disconnects itself. Sometimes i can’t copy stuff to my external. Where are these problems coming from? :smiley: Now i’m thinking that i should format it and make it NTFS! Any ideas?

Sure , but Remenber To Copy your Data somewhere else Before formatting the unit ok 

Hello I just got a WD external HD and when I connected it to the PC windows has detected a new hardware and went looking for drivers but didn’t find anything. So my question is where I can find drivers for it? I’m not sure what kind the HD is but I’m sure it’s not passport or legacy or elements.

Easy One :slight_smile: , If your Drive Comes with The WD Smartware you Can Find the Wd Ses Drivers Inside

of the WD Smartware Virtual Cd under the Extras Folder …

If you Have any other Info let me know :slight_smile:


Click the Kudos star to say thank you for helpful posts. And be sure to come back to click the ‘Accept as Solution’ button for the post that solved your issue. This may help someone else.

Hey hey. :slight_smile: So after spending some time to figure out what’s the problem with my hdd , i got it. The trouble maker was called : Power Options. The default was set to “Balanced”. I changed it to “High Performance” and everything went back to normal , only after 20-30 minutes of using it , it stuck! I went to check the Power Options and found that hard drives turn off after 20 minutes. So i set that to never and now everything works perfect! :slight_smile: I hope this thread won’t get deleted because i believe that there will be more people who will end up with the same problem. And i hope that it will help someone too…

There u Go! :slight_smile:

1 Like

Hey,

I am having a very similar problem except with 2 My Passport Elite Drives.  When I click on the setup icon I get the acceptance window for the WD License Agreement, but just like above, there is no text on the buttons.  Clicking on the left button brings me to the next screen which behaves even more erratically. 

I have tried downloading the newest Drive Manager and still get the same behavior, and I have Flash, Java, and using WIndows 7 English. 

HDD Did work great with my XP laptop though. 

Any Suggestions?

Did you read post 2 and see if your Java and Flash Player are up to date?

Joe

When I try to install Passport on my computer with Microsoft 7 operating system, I just get a blank when I should press “accept.”  Then I just get a “Catch 22” situation where it keeps returning to the starting point.