WD SES Device USB Device

Hi,I have a 1tb wd my book,it was working properly for the last 1 year but today voltage fluctuation took place and now i can see its connected to the PC but i can’t access it,it’s hidden somewhere in my computer and the same “wd ses device” problem is there in the device manager but i cant use smartware since i cant locate my external drive in my computer…HELP ME OUT PLEASE…i dont want to replace it bcoz i have some important documents in it which i dont wanna lose at any cost

Hi there, you can get the SES drivers from here, just download the file for your OS (32 or 64 bit), right-click the SES device on device manager and select update driver, the search for the SES.

If the drive is still not seen after reloading the drivers, then check if the drive is on disk management (Right-click on computer/my computer> manage> disk management) and see if the drive is there without a letter, or raw, or healthy or unallocated.

mybook.JPG

yup the harddrive is without a name,healthy n there is a blank in  file system …i have posted a pic of my disk management also…i have installed ses driver but still not worthy of it…what should i do? HELP ME

Clipboard01.jpg

The first two are the drives of my external harddrive

Dude, the drive has lost the file system, you’ll need to do data recovery…

Try TestDisk, it is free and has helped a lot of users in here…

wher can I find TEST DISK?Can you please send me the link…

Quick Google search: The very first link, here you go.

http://www.cgsecurity.org/wiki/TestDisk