WD Remote Smart phone App not detecting WD Devices

I purchaes two WD TV Live Streaming boxes and updated them to the latest firmware straight away.

The two devices can be seen on my private Wifi network (using Windows Vista)

However, when I run the WD Remote App on my Android phone, they do not show up. Also, if I run the WD Remote app on my Apple iPad, same issue, no devices in the list.

Am I missing something here? The phone and iPad are both on the same Wifi network.

1 Like

Since you cannot connect from both, phone and Ipad, make sure that all of your devices are connected to the same router and all are on the same IP range, and has the same network Subnet Mask and Gateway.  

Hi Vadir, Any tips on how to do this? 

Thanks

My router has an IP of 192.168.1.254.

Everything else has an IP of 192.168.1.X  , startiing from 1 and increasing up. They are automatically assigned when each device joins the network.

How can I see which Subnet Mask and Gateway are being used?

What is the default for the WD TV Live box? Maybe I need to change this in the Router config, would that be a solution?

"Since you cannot connect from both, phone and Ipad, make sure that all of your devices are connected to the same router and all are on the same IP range, and has the same network Subnet Mask and Gateway.  "

Any more details on how to do what you suggest? Not sure how to check these.

1 Like

I had the same problem with my wdtv hub running on the latest firmware update. The wdtv remote app worked on an android phone and the device was listed but the iPad wdtv app running on iOS 5.0.1 didnot detect any devices. I also have the 8player app installed on the iPad and that too failed to detect the hub. My wdtv hub was wired to the router and the ip address for the wdtv was 192.168.0.100. You and find the address by going to the network settings of your wdtv player. Here is what I did to get the iPad to detect the hub. Open Safari and type in the local IP address of the wdtv player. In my case it was 192.168.0.100 The wdtv device page opens and prompts you for a password. I think the default password is admin. Minimize safari and open the wdtv remote app or any other video streaming app and it should automatically detect the player. After I did the above, subsequent detection of the player by the apps did not require me to perform the safari login step. Hope this works for you. Ps. I can,t seem to edit post to make it more readable. Sorry it’s all in one paragraph.

i had the same after updating the firmware. all i did was remove the app from my phone and install it again. all works fine now. :smiley:

Have the WDBHG70000NBK and latest firmware. Also have ios latest firmware. Both iPhone & wd device are connected to same wi-fi with same subsets etc. I install the remote app today, but it cannot find the device. Anyone know why??

1 Like

This worked for me to get the mobile app to detect my WDTV Live. I use a Galaxy S2 that is connected by WI-FI and the WDTV Live is on a WIRED connection. Both my WDTV and Galaxy S2 have the lastest firmware, app etc.

On Android ICS 4.0.4 go to - Stettings -> Applications.

Then find WD Remote, in the “Downloaded” tab. Select (tap/click on) the app for “app info”

Next tap on “Force Stop” then finally “Clear data”

*Note* I had the WDTV switched on while fixing the mobile app… Tho I believe this solution should work regardless.

iPhone, iPad users… try the same solution. I can’t provide instructions on doing so in iOS, as I don’t use those devices

1 Like

the solution in above post has been working for me too… since last app update

Thanks, phlux85. I was just about to remove and install

i have a WD my net N600

it works great with my samsung tablet and my LG phone but will not connect to my Ipad  Model MD513c/A

You need to make sure in the router UPNP is enabled. This is disabled in new routers due to security.