WD Red NAS Hard Drive - Formatted by Windows 10, now can't be seen


Not a SATA expert, hence not successful searching for the solution to this.

I have 2x WD Red NAS Hard Drive 2TB that I’ve removed from my QNAP NAS server (replaced with SSD).

I connected one to my Windows 10 PC using a powered SATA adapter and followed the prompt to format it. I chose the non-quick option and the format process took several hours.

When the process ended, I think I saw a message saying that Windows was unable to format the disk, but the process seemed to end normally otherwise.

However, now, when the drive its connected, several errors occur:

  • The drive can’t be accessed in file explorer - although several drive letters do appear, non work
  • After a time, the prompt to chose what happens to external disks, and the one to format a disk appear
  • If I run disk management with the drive connected, the connecting to the virtual disk service hangs
  • If I run disk management and then connect the drive, nothing appears and any attempt to rescan hangs

Sooooo, I’m unable to connect to the disk, unable to format it, and not sure if I have any options for restoring it.

Perhaps I shouldn’t have formatted it in the first place?

Thank you in advance for all help.

If it was my drive I would connect it USB then use MiniTool Partition Wizard Free to remove all partitions and then make new partitions and format them.

So if you don’t want to use Minitool take a look at THIS and use diskpart which you already have in Windows.