WD Red 4TB lost capacity

I have a problem with this drive, I can not regain the capacity to 4TB. I have tried with Techtool Pro on a Mac I have tried DLGDIAG tool from WD and Acronis, I have also tried with Linux to format. I have used diskmanager in Win and diskutility in Mac but the capacity for this drive never exceeds more than 1.8T. How can I regain my lost 2TB of space? I did not get an answer from support so I am frustrated with this problem.

Is there any software that can reset the drive to factory default? Why does this error occur and where is the problem? I never had this kind of problems before.

I put this drive in an WD My Book enclosure as I needed a larger capacity drive for a temporary backup of another drive. I did an image for the backup. All was fine as there was 4TB of space on the drive. When done with the backup I did reformat the drive and after this I have not been able to get back my 4TB. As you can see on the screendumps even after zero the drive it is still only 1.8TB on the drive… it worries me when even a software from WD can not see the capacity of the drive…

Regards

Soren

WD4_test_passed.JPG

Problem solved!

Thanks to NAS Linux server!

I attached the drive to a NAS server and reformat the drive from there and it did find my lost 2TB. Great!

Back in business!

1 Like