WD Quick View not detecting MyCloud on the Mac

I have the latest version of “WD Quick View” installed on my Mac (OSX 10.10 Yosemite), and MyCloud is running the latest firmware version (v04.01.01-413).

The issue is that “WD Quick View” doesn’t find MyCloud on the network (and so doesn’t show any of the options to control it). The only menu item that it shows is the “About WD Quick View”, like you can see in the figure below.

WD Quick View can't find MyCloud

It’s worth mentioning that all the other options on that menu have already appeared ocasionally, but it’s somewhat of a rare event. If it happens because of something that I do, I can’t see what it might be… :(

So, my question is, why is Quick View not finding MyCloud? Is there a way I can force it to refresh?

This issue appears to have been reported before, but I’m not sure if it’s really exactly the same one. Most of the other threads that I find about this mention the Windows version of Quick View ( [1], [2], [3], …)

UPDATE:  Just found another clue: The WD My Cloud Desktop App also can’t find any device on my network! When I use the “Search for devices on my network” option, all I get is a “No devices found” message. What can possibly be stoping the MyClound devide to be found by these apps, considering that I can find it through Finder and through a web browser? :S

Thanks in advance!


What happens if you reboot your computer?

Posted by,
cat0w (USA)

What happens if you reboot your computer?

Well, now that you mention it, that’s another issue… :slight_smile: When I restart the computer the “WD Quick View” icon doesn’t show on the menu bar, even though I can confirm the process is running if I open up the Activity Monitor. If I use Activity Monitor to kill the process and if I then start it again, then the icon shows up on the menu bar, but it still doesn’t detect MyCloud :\


Something like this happened to me after I installed the 408 firmware update, and reconnected my safepoint backup drive. The MyCloud also could not mount or be found using any method I knew. I finally fixed it by power cycling the MyCloud by unplugging it. It’s worked fine since.

Quick View disappearing has happened on and off since I bought the drive, though not since the last firmware update. No idea why it should be connected with the firmware version. I simply go into the directory where the app is located, and double-click it to relaunch it. Then it’s fine.

I’ve shut down de device and booted it again. Quick View behaves just the same after the reboot :frowning:

… but the WD My Cloud Desktop App now detects de device without a problem.

This says to me that whatever the reasons for both programs not to work, they weren’t the same. 

Do you guys/gals have any additional advice to make QuickView work? :\


Continuing to debug this issue… I tried figuring out exactly which connection is QuickView trying to establish when trying to find MyCloud on my network. I ran this command on a terminal when starting up QuickView:

sudo lsof -i TCP | grep -i wdmycloud

… and the result was:

WDQuickVi 2674 fcorreia   28u  IPv4 0xf3510856f52b03e1      0t0  TCP mymac.lan:50039->wdmycloud.lan:https (CLOSE_WAIT)

WDQuickVi 2674 fcorreia   29u  IPv4 0xf3510856f52b03e1      0t0  TCP mymac.lan:50039->wdmycloud.lan:https (CLOSE_WAIT)

But I tried accessing the address https://wdmycloud.lan on my browser and it opens up the MyCloud panel without an issue… so I’m back to square one :\


I have the EXACT problem.

I’m on Yosemite 10.10.1

WD Quick View V2.4.4.2

I’ve tried running MyBookLive Setup1.2.22 and it can’t find the device on my network.

And like you I can find it by the WD My Cloud App already installed and manually from its IP address via finder.

I’ve uninstalled the ‘quick view app’ and then downloaded a fresh one, reinstalled it and now that dosent even appear on the top bar!! gone from bad to worse!!

What the **bleep** is going on? I can’t run ANY of the diagnostics or settings on the drive :-@

WD - NOT HAPPY please help

Yes, I have the exactly same issue as you, feel sad about the WD

I have the identical problem.  MyCloud app connects fine, web connects fine, Quick View can’t connect.  Restarted, rebooted, re-everything to no avail.

Does WD look at these forums?

WD do not respond to this public forum. It is a user-to-user forum. Your best bet is opening a ticket for support.

(try giving your wdmylcoud  a reserved address in your router. Look for DHCP reservation. Normally you don’t have to, but it seems there is a lot of misbehaved routers).

This is still happening even on El Capitan!
I get the EXACT problem but it comes and goes - i used it yesterday to rescan the dnla server so the TV could see the new files I put on it. Today - nothing - NO drop down menu again web access stopped to Grrr…
Why isn’t there a fix for this yet? it’s obviously a problem but there’s been no software update since v2.4.6.2

Exactly the same issue here, El Capital, most of the times My Cloud is not found although it can be accessed through the IP or My cloud app. However, My cloud access and quick view simply do not work, as outline above. Occasionally, the NAS is found…frustrating…

There are several known issues with El Capitan and the My Cloud. See the following thread for more information.


This issue is more than two years old; it is much older than El Capitan.