WD Quick View Mac 10.12.x Sierra

Trying to install WD Quick View version on Mac OS Sierra 10.12.x gives an error “cannot find the necessary files” and the installation fails. Is there a new version compatible with Sierra coming soon? This is an invaluable menu item for me as a user and as a computer tech for my Macintosh clients.


Sorry to hear that.

Did you tried downloading the application again from the WD support site?

Also, you can try using the WD Access. This is a utility that will discover your WD Cloud device on your network and provide you tools for uploading files, access to the WD Cloud dashboard and other shortcut features.

Have you got the Arial font pack installed? Previous installation problem reports have identified this as a requirement.

Yes, I have tried multiple times with multiple computers running MacOS Sierra and the same thing happens.

And even the WD Access application for Mac did not recognize a brand new drive. I had to search the router for it’s IP address and use that in a web browser to finally get to the setup page.

WD needs to fix these apps immediately, please!

Isn’t the “Arial” font pack part of a brand new MacOS Sierra installation?

I have no idea; I don’t own a Mac. But check out the previous reports:


No idea if this is your problem, but it might be, since the previous reports were installation problems due to Arial not being turned on in the ‘Font Book’

I have the same problem. On two imac´s, QuickView was installed bevore upgrade to Sierra. On this, QuickView works after update to Sierra.
On my macbook i try to install this tool afterk updating to Sierra. Installation of QuickView failed. Arial fonts are installed. Can anybody help? Thanks to all.

Quick View seems to be an EOL software so I don’t believe is gonna be updated in the future. However there is a way to install it on Sierra.

  • Right click on the installer and click on Show Package Contents.
  • Go to Resources folder.
  • You will find the right installer with the name WD Quick View Installer.mpkg
  • After the installation you may have to reboot the computer to make it work.

Hello dan_sp

thank you for this information. It works well. :+1:

Hi dan_sp

thank you for your tip.
Finally got the installation working.

But I have an issue with Finder.
I see the shortcut on the left panel for my WD Live Duo Drive.
I can connect the drive with my username and password and see the folders.
As soon as I try to open any folder it closes the Finder window and says that the original folder cannot be found.

Any idea for a solution?


Thanks a lot for this hint from dan_sp with going into the “Show Package Contents”. This is a very new experience but worked so well after two days of frustration!!!