WD Print Share problem - SOLVED on N900 router - Canon ip3600 printer

I had the problem below but I just noticed that when the Print Share control panel is open and the printer has been detected there are other options available by clicking right over the printer name. One of the options enables auto connect.  I don’t recall this being mentioned in any documentation but if it isn’t it really ought to be. Alternatively perhaps the options should be on the main menu.

When I run print share it recognises the printer but only gives the option to connect or disconnect manually. When connected the printer behaves normally. It is a pain having to manually connect and disconnect the printer from the Print Share control panel and what I want it to do is to connect automatically. However the printer does not show up in the Print Share Auto Connect list and I can’t see any way to add it. The router firmware is up to date (at 15th december 2012) and I have downloaded and installed the latest version of Print Share (2.41) The printer is a Canon ip3600

Nice, thanks for sharing.