Wd portal not working

I’m triyng to create an account and it is saying registration unsuccessful.

Delete cookies, refreshed browser and nothing is working. Is your system down?

What WD device do you own?

No, my system is up and working just fine.

Hello, same trouble here. I am in the Philippines and I trying to create a My Support account on the Portal I keep getting a “registration unsuccessful” error. Tried both FF & Chrome
Funny that in Chrome I didn’t have to do the "click all items below Captcha, just click the check box

I also tried to submit under the “Ask a question” and I get the same type of error message (Can’t remember exactly what it was, but it was along the “unable to submit” line.

Cheers, MadDogDean

Interesting… No sooner than I replied to the forum, I received a “Congratulations on registering your XYZ product email” from WD. Perhaps the registration is working, just a page redirect issue on the Portal Registration.

@pbrownn23, check your email (including the spam) if anything came in.

Cheers & good luck

EDIT
However the password doesn’t match what was used to register and if I try to reset it, I get a message

“Root element is missing.License Limit Exceeded” on page
https://support.wdc.com/support/accountpassword.aspx?sfacc=(my secret hash here)&lang=en

why i cant change my password. i see this error on the page load, event before submitting the new password.
Root element is missing.License Limit Exceeded

I’m triyng to create an account and it is saying registration unsuccessful. Delete cookies, refreshed browser and nothing is working. Is your system down official site?

I am in the Philippines and I trying to create a My Support account on the Portal I keep getting a “registration unsuccessful” error. Tried both FF & Chrome
Funny that in Chrome I didn’t have to do the "click all items below Captcha, just click the check box

I also tried to submit under the “Ask a question” and I get the same type of error message (Can’t remember exactly what it was, but it was along the “unable to submit” line.myfirstpremiercard