WD Photos not displaying photos

Hi all,

WD Photos does not display photos at all. First of all, yes, I have tried the solutions as outlined using the link below and it did NOT work(e.g. rebuilding database, turning remote access off and on aagain, etc.). I have also explored other solutions provided in this forum but nothing fixed my issue.


What I find strange is that WD Photos keeps on asking for the NAS password instead of the code provided when setting up the remote access  (see picture below).:. However, I can also manually add My Book Live Duo using the “correct code” but this doesn’t solve the issue (e.g. still no pictures appear).

WD Photos asking for NAS PW

When I enter the NAS password - WD Photos appears like connected to My Book Live Duo but no pictures appear. See below:

No pictures appear

I thought it takes some time to resolve but now I have waited d+1 week and nothing changed. Can somebody help me?

Further Background:

  • All my pictures are stored in the folder “Public”

  • I have added pictures to see whether it gets my My Book Live Duo moving - nothing happened

  • I can see all picutres on WD2Go app - no issues there

  • I have re-started NAS several times.

  • I have the latest firmware

  • The device (IPAD - WD Photos App) appears as “connected” on the My Book Live Duo webinterface

It would be great to get your views on my issue. WD Photos is very cool but only if it works

Thank you in advance

I have gone through the whole forum.



WD really disappoints me. No reply, no help, product is corrupt.



In what folder are your photos stored?

it is stated above already - in folder public

Not in Public/Shared Pictures?

all pictures are in public/shared pictures