WD Photos / MioNet - Error 668

I set up MioNet and the WD Photos app on my iOS devices last week, and it was working very nicely.

This week, I started getting a “Device is offline. (668)” error message when trying to remotely access my media using the WD Photos app.

The only solution? Go in to the HTTP UI and reboot the device. This fix is temporary however. Try to use WD Photos again the next day and sure enough you’ll see the same Error 668.

Another observation: while WD Photos tells me the device is offline, it’s actually not, because it can be accessed from local computers through AFP or SMB in the file system. So this has more to do with MioNet/remote access features.

What’s the problem and how can it be fixed?

Can you advise from the Device UI what the current firmware and Mionet version is?

You can find this in Settings-System tab- and it is under the section Updates.

You should see "MyBookLive: 01.xx.xx Mionet :4.3.1.xx

Every WD-Mybook-Owner has the same problem.  My brother, two of my friends and I.

We all have the latest firmware installed.

After rebooting the WD-Mybook everything is fine. I can use my iPad or my iPhone to see all my photos with the WD-Photos-App.

But, one day later I just get the Error-Message: “Device is offline. (668)”

The only solution I’ve found: Restart the Mionet-Service and all will be fine. But just for one day…

  1. I can´t believe that this Error is knew to WD. I think it is well known, because many Users report it all over the internet.

  2. In germany our internet-service-provider performs a daily disconnect. So every 24 hours, we receive a new IP-Adress. Is it possible, that the Mionet-Service is not able, to handle with this ?

The WD-Mybook is good.

The WD-Photos-App is stunning (if it runs).

So it would be nice, if WD is able to find a solution for us.

I look forward to your answer…

Everything worked good for a few days when I first installed the My Book Live, and now the app on my own network states its offline when it is not.

I wanted to demo this to potential clients of mine on their networks, will have to wait to this is fixed.

My Book Live Firmware

MyBookLive 01.03.03 : MioNet

So following steps were done to get it working, for now;

  • Logged into MybookLive via computer, and rebooted device (same error)

  • Uninstalled APP from my IPHONE4 (same error)

  • Rebooted IPHONE4

  • Reinstalled APP (same error)

  • Launched and logged in (same error)

  • Logged out

  • Logged in and it worked.

There is obviously a problem sense there are many people having this problem, and others state they are doing this almost daily to get it to work, that is just not a good solution. Mionet has to take a look at that especially if they are selling the service and I cant even get it to work efficiently on my own network.

I run an Apple Extreme dual-band Gigabit network, and the viewing (loading) of photos is pretty slow and not understanding why with my fast network.

Found a similiar posting concerning the My Book World and Error 668


Not sure if this is happening but the trigger event, is losing network conectivity or un-plugging the network cable, both of the items I am not doing. I have not tested this, but I would believe setting it up for a static should fix the issue for the My Book World and possibly ours? I will test tonight.

01.02.06 with MioNet

Ever since I turned off the energy saving feature, I have yet to encounter a problem with the code 668. I still get a network link intermitting problem, not sure why, my network is stable but oh well.

But since I turned energy saver off, and reloaded the WD Photos App, no issues besides just being slower than I expect on my own network.