WD Photos is not connected to the internet (-1009)


#1

Hi,

I can’t seem to access WD Photos from either my iPad2 or iPhone 4 both on Wi-Fi.  I log into My Book LIVE and add mobile access, it gives me the code which I enter onto my mobile device, it says First Time Setup and then dsplays the error message WD Photos Network Connection Failure (1) and then WD Photos is not connected to the internet (-1009).

I have MyBookLive version 02.10.09-124 : core F/W and the latest software apps on the mobile devices (version 1.3.2)

I have tried uninstalling the apps and re-installing but to no avail.  On the MyBookLive screen it just continually says waiting where the device should be.

Not sure what is going on here but one of the reasons I purchased the MyBookLive was the access to photos and videos etc it afforded me.

Does anyone have a solution or does anyone at WD have an answer?


WD Photos is not connected to the internet (-1009) (cont'd)
#2

Have you try connecting to the internet with any other application from your iPhone or iPad?

You can try resetting the MBL to get another code but this error usually indicates a connectivity issue.


#3

I have same problem:

Please note :

Other application from Ipad works perfectly

I have reset the MBL and obtain new code., same problem

Please your assistance will be appreciated


#4

The same thing is happening to me. When I’m on the same wi-fi network as my WD TV Live Hub, I can upload photos fine, but if I try to us WD Photos app on iPhone to view the photos stored on the hub, I get the (-1009) error after a “first time start up” dialogue.  If I turn off the wi-fi and go to 3G or I’m on another network, I can’t even upload photos, and I get the same error.

I checked, and I have the latest version of the app and the latest firmware on my WD TV Live Hub


#5

Same problem but finally I have found the solution. The key is that you need to install FIRST the WD2go utility and you should activate it as usual with the access code given by the My Book Live Remote Access web config page.

Enjoy it! :wink:


#6

WD2Go is not an option for me, with the WD TV Live Hub. I still get the -1009 error every time.


#7

Bump

anyone have any help here? The app just doesn’t work, it won’t get past the “First time setup” screen.


#8

I have the same problem after clearing cashe. With bugs like this I wonder how secure my drive is no a network.


#9

Same problem!


#10

I had a long phone chat with an excellent WD tech support guy. Turns out it was a router setting that kept my app from accessing the Live Hub, giving this error. IMHO, it’s a mistaken error code. The app is connecting to the internet fine, it just can’t connect to the Hub.

So, we put the Live Hub’s IP address in the rounter’s DMZ, and also disabled UPnP and viola, it connected. 

it took about 10 emails back and forth to tech support, where they were full of nonsense ideas, and then I posted to the WD facebook page about my frustrations. I got a call on the phone the next morning and the problem was solved quickly and efficiently.


#11

Hi , I am glade you have solve your problem, please provide me  more detail  how you have solve the problem.

Thanks


#12

If you turn Remote Access “Off” and then “On,” it should re-establish the remote access connection. In some cases, after a firmware update, Remote Access did not work correctly until you’d turned it off and then on.


#13

I have the same problem.

I’ve reinstalled it, and works one time only, they never again.

Too bad some does not release a good piece of software!


#14

Any one found a fix yet? Tried all suggestions and still not working. Very frustrated. Works on my original iPad, but not on iPad3


#15

I had the same problem with my iPhone 4 and WD MyBookLive showing the message: not connected to the internet -1009 when using the WD Photos and WD 2go apps. Yesterday I found the solution that worked for me:

First switch off WiFi on your iPhone, so you are just using the 3G connection. Then request for the codes you normally do on the dashboard of your WD MyBookLive and fill in those codes on your iPhone for both apps. The apps will work perfectly. After that, switch on WiFi again on your iPhone. Now the apps will work both on WiFi and 3G.

Good luck and let me know if this worked for you too. 


#16

It worked for me :slight_smile: