WD Photos General error. (500)

Hello Community members,

I am new on this community and would like to share the problems i am facing with the WD Photo app

I purchased a MyBookLive 2TB. (i am verry happy with this device…!)

Installed it and with a few click i got it up and running. On my Iphone with IOS 5.0.1 i installed the WD 2go and WD Photos app. The WD 2go works perfect on my home Wifi and over 3G outside my Wifi range. I coppied a few photos in the Shared Pictures folder in the rooth (all jpeg) and can acces them over the WD 2go app. Everytime i start the WD Photos i see MyBookLive on the startscreen. When i click on MyBookLive then i get the following error message:

WD Photos

General error. (500)

I also installed the WD Photos classic app which gives the same error message.

I tried with 2 other iPhones with different IOS and a android phone but get the same message. On all phones the WD 2go workes fine.

Uploading photos from the WD Photos app from the photo roll to mybooklive goes ok and photos are posted in the  

shared Pictures folder

I searched the forums on error message (500) but cant find a solution or a simulair problem.

Does anyone have an idea what is going wrong?

Thanks in advanced for helping out…!


try uninstalling and reinstalling the app

Same problem and reinstall does not fix. Any other thoughts? Thanks

Just tested on a second iPad (new model) which was working and that now gives the same “General error (500)”. I have recently added a large number of hi-res photos to the N900 could this be the problem? If so, how to fix? On the internal network browsing folders and photos with a PC  (Public/Shared Pictures) look fine.  WD2go can access the pictures OK too. Any thoughts? Thanks

Further to the above. It seems that the system “re-found” the iPAD without reconnecting from fresh. I have deleted it from the N900 and from the iPAD and then needed the activation code to restart. Looks like it may now be working as the photo library is starting to build.