WD Photos: First Time Setup... 40%... 86%... Unable

Subject lines says it all: I cannot get past the first time setup for WD Photos on either of my Android devices.

I’ve removed all of my cloud access devices and re-created them, manually, using the Activiation code on the local wireless network.

I can access my files just fine from Android and Mac, using the WD MyCloud apps.  And, when I look at the web UI, it lists WD Photos as a connected Cloud device, but I cannot get past the initial setup.

I’ve removed/reinstalled the app and repeated the steps above.  But when I add the WD MyCloud to WD Photos, it goes through the First Time Setup process, showing 40%… then 86%… hangs for 30 seconds and then says: Unable to access device.

Have you contacted support about this issue?


I have not… I anticpate being told to reinitialzie the system to factory defaults and try again, which seems to be a common solution.  I am taking a break from MyCloud for a while; this has been too much work.  When I feel motivated again, I will contact support.


Well… I re-ran the System Only refresh and no change.  I was receiving error messages about the WD MyCloud being unable to complete a Media Scan.  The refresh and subsequent rebuild / media scan seems to have taken care of that.

However, I cannot get past the initial setup for WD Photos on either of my two Android devices.  I’ve tried deleting / reinstallling the app; deleteing and re-choosing my device (both from the local network option and the activitation code option).  Everytime I get Unable to access device.

I suppose it’s time to open a support ticket :frowning:

I have the same problem. My WD photo app was working perfectly before but after re instaling the app and activating with the new codes, it initializes and does first tim set up and stops at 86%. A pop up then appears and indicates" cannot access device"

I already did a soft reset and problem persists. Although my other app WD mycloud works fine, but my WD photos on my android S3 and Note 8 does not anymore

Good luck… I was never able to get this to work, despite reinstalling, re-initializing the MyCloud device, et al.

I will keep monitoring this thread and please post back if you figure something out.

Did you get your WD photos running. I have no been lucky so far even with support

Appreciate your feedback

Has everyone tried these steps found in the Learning Center.

( http://setup.wd2go.com/?mod=faqs&device=mc&faq=accessContent )


Posted by,
cat0w (USA)

From my original post:

“I can access my files just fine from Android and Mac, using the WD MyCloud apps.”

So, yes, I have done “Action 5” and it works just fine with the WD MyCloud app - just not with WD Photos.

I escalated this issue. You may be contacted for further information.

I have exactly the same problem und tried all tipps found here again and again.
The Problem only exists on a mobile with Android 2.2, onother with Android 2.3.3 works fine after several retries to the first time setup.

Has anybody got a solution?

I fixed it by re-initializing the WD MyCloud, removing/reinstalling the Android WD Photos app and then setting up the app with a small number of photos of the WD MyCloud (i.e. like 12 photos).  Then, I was able to get through the setup process.

I’ve stopped using the WD MyCloud for my documents (I have LOTS of documents with included images) and use it only for music and photos.

Good luck… you will need it with this device.