WD photos error message: NSURLErrorDomain error - 1200


I have found a previous thread on this same problem but it doesn’t have a solution:


I have added my mybooklive to the WD Photo app through wi-fi, and it shows in the ‘mobile access’ part of my dashboard as connected. However, though connecting through wi-fii works fine, when trying to connect through 3G I get the message:

The operation couldn’t be completed. (NSURLErrorDomain error - 1200).

Can anyone help? Someone on the previous thread suggested checking UPnP was enabled in my router. I don’t know what this means, but I can see it in the router settings and it is enabled. Someone else suggested something about a port conflict…I don’t know much about this either. I thought these drives and apps were meant to be easy to set up and use? Most people don’t want to be dealing with things like port conflicts. Any help would be much appreciated.

The WD 2go app works fine for me, it’s only the photo app that’s having this issue.

I am using an iPhone  4, iOS 5.1.1, WD firmware version 02.32.05-046

Is anyone having the same issue? It’s not just a problem of 3G I’ve discovered, as it also happens over wi-fi networks other than my own. So I actually can only use my remote access when I’m…at home. Not really what I wanted this product for. Anyone have any thoughts at all? Thanks…


has anyone found a solution to this, i have just set up my WD 3TB My book and i can access WD2go app and see all my files. i can access the WD photos app when i am connected to my network at home on my IPhone 4s but could not upload photos from my camera roll when i was at work or connected via 3g. tried to delete the app and set it up again and still no joy. this morning i tried again and now i can not even access the photos which i could yesterday? Any help is much appreciated.