WD photos error message: NSURLErrorDomain error - 1200


I have found a previous thread on this same problem but it doesn’t have a solution:


I have added my mybooklive to the WD Photo app through my wi-fi, and it shows in the ‘mobile access’ part of my dashboard as connected. However, though connecting through my wi-fii works fine, when trying to connect through 3G or wi-fi anywhere else I get the message:

The operation couldn’t be completed. (NSURLErrorDomain error - 1200).

Can anyone help? Someone on the previous thread suggested checking UPnP was enabled in my router. I don’t know what this means, but I can see it in the router settings and it is enabled. Someone else suggested something about a port conflict…I don’t know much about this either. I thought these drives and apps were meant to be easy to set up and use? Most people don’t want to be dealing with things like port conflicts. Any help would be much appreciated. It’s slightly infuritating only being able to use my remote access from home.

The WD 2go app works fine for me, it’s only the photo app that’s having this issue.

I am using an iPhone  4, iOS 5.1.1, WD firmware version 02.32.05-046

I have also tried posting this in the software section but didn’t get any replies so thought I’d try here. Any thoughts appreciated!

Try to download the updated WD photos. If still not working update the drive firmware.

Thanks a lot for your reply but I have the latest version of the photo app and also my firmware is up to date (MyBookLive 02.32.05-046 : Core F/W).

Try contacting WD phone support 1 (800) 275-4932.