WD Photos App - Unable to connect remotely


I only have had my 1TB MBL, and am starting to get things configured etc.

We both have iPhones, and an iPad all running iOS 6, and WD2 Go and WD Photos. However, within our Wifi WD Photos works fine, with no issues. However, the app cant seem to connect when I go onto Wifi at work, whereas the WD2Go App works flawlessly.

I have a UPnP router, and according to the MBL UI, it has a direct connection via the “automatic” connection method. 

Is the WD Photos app desgined to work remotely, or within the wifi. I know that this App doesnt work over 3G.

Any help would be most grateful, as the only reason why we purchased the MBL was the ability to use it as a personal cloud, and to view photos from anywhere on any device.



It should work “anywhere” you have access to the internet.   Via Home WiFi, public WiFi, or 3G.

If it’s only not working from your work network, might there be a firewall rule in your work network?

Its a “public” wifi on a separate internet connection that staff and visitors use, and not connected in anyway to our work network. 

Ill try it again today, this time waking the device up using WD2Go and then use it. I dont have a static IP at home, but the device has a static IP assigned by DHCP.

is there any thing else I could try?


I have tried again, but to no avail. Again, WD2Go works fine with no issues.

Looks like ill move my photos back to use on WD2Go unless this is sorted. The whole point of WD Photos is to be able to view all the pictures, if this can be achieved with WD2Go instead of having to download the photo first, then it would be a great app!

Ive been reading around and it seems that ive got to register my MBL with MioNet or something? Is this still true? I cant find any reference to it on either MioNets site or on the MBL site.

Could I please have a response from WD? If I dont get a satisfactory response from WD themselves, ill be off to another provider.

No, MioNet is no longer used on the MBL series NAS boxes.   That was used a very long time ago, but even then, MioNet registration wasn’t necessary.

I’m sitting here at work on our Public WiFi and WD Photos is working fine for me on both my iPod and iPad.   

Have you actually already “paired”   WD Photos with your MBL, or are you trying to do that from work?   (That won’t work, if that’s what you’re trying.)

Have you tried Force-Closing the WD Photos app and restarting it when you’re on your work network?

  Could I please have a response from WD?  If I dont get a satisfactory response from WD themselves, ill be off to another provider.

WD doesn’t do tech support here.   This is a user-to-user forum.   

You need to go through WD’s support if you want them involved.

Hi TonyPH,

Thanks for the response. I have just tried force-closing the app, and when I enter I get an error:

“The operation could’nt be completed (NSURLErrorDomain error -1200.)”

As my MBL goes to sleep, I accessed it using WD2GO (as this usually wakes it up), and force closed the App and retried, but I still got the same error. I am running Firmware: 02.11.09-053 as this seems to be the most stable firmware.

What Firmware are you running? Do you have any ports forwarded to your MBL?


Just re-read your post. I have already got an “activation code” from within the UI when I was at home, and the app is listed under “Mobile Access” in the MBL UI.

I don’t know exactly which version I have on there right now.   Can’t get to my server from Work since I did a Fedora upgrade a few weeks ago.

But it’s the latest that was released a few months ago…

Port Forwarding for WD 2go and WD Photos in my case are all automatic via UPnP.   If I could log into my server, I’d be able to tell you what ports it’s actually using.  :smileyvery-happy:

Im currently backing up the contents of the drive (lucky there isnt much on there) before I upgrade the firmware on the drive.

Ive re-checked my router settings, and UPnP is enabled, and appears to be working as expected. 

Just hoping that its the firmware thats the issue here!

Thanks for your help so far.

Firmware now updated to latest version, and still the same error.

Im thinking of contacting WD support as this is getting ridiculous now! Is there anything else I can try?

 Its a “public” wifi on a separate internet connection

I would look in your router to see what TCP Port UPnP assigned for the WD Photos service, and then also ask your IT department if those ports are allowed through your work firewall.

Just because it’s a “Public” wifi doesn’t always mean that all ports are allowed.   My Corporation’s Public network only allows like 8 TCP ports and a handful of UDP ports to connect.

We use a separate broadband connection for the office wifi. This is just a bog-standard ADSL line going to the internet. Due to the nature of work we do, the traffic on this line is not filtered in anyway.

Plus, I get the same error on 3G. My wife has a proper public wifi (BT Openzone), and it still doesnt work on this either. It also doesnt work from my Mum & Dad’s wifi (20mb Fibre) connection.

I think this definitively proves that it cant connect to the MBL though my router, but I dont know why.

How do I check which ports its using? I have a Huawei HG533 router provided by my ISP, and UPnP is enabled. This was the first thing I checked when I was having issues.

Lightingman2003 wrote:

How do I check which ports its using? I have a Huawei HG533 router provided by my ISP, and UPnP is enabled. This was the first thing I checked when I was having issues.

That’s a good question.  Different routers do it different ways.  Unfortunately, some routers don’t allow you to see that at all.  My Verizon-provided FiOS router has a summary page of every UPnP port, which device requested it, and its current status.

As I dont think I can get the which UPnP ports are being requested from my router, can you tell me which ports your WD Photos app uses, and Ill turn on port forwarding for them ports.

If that doesnt work, then I dont know what the issue is, and ill have to call WD!


Hi TonyPh,

just to let you know, ive found the cause! It appears that some routers do not like UPnP connections.

it was advised in the below post by WD to turn off UPnP and force a relay connection.


after turning off UPnP, it works!! Even over 3G. Granted its slow, but im just glad its working!! Ill find a proper UPnP enabled router! 

Thanks for your help!

Awesome.  Glad you got it working!