WD Photos app blacks out on Apple TV

Hi Everyone,

 Received Apple TV for X-Mas. I have an iPad (4th gen) and connected it without a problem. I mirror the iPad and see the home screen and icons fine. Everything works except WD Photos, which blacks out the entire screen when I run it. Collapsing the app by hitting the home button twice displays the shrunken app correctly, but when tappped to enlarge, the entire screen blacks out on the TV. The iPad screen displays the app correctly. Oddly enough, a friend has an older iPad (gen 2) and WD Photos works fine. What am I doing wrong?

Hi Haraden, verify if you have the latest version of the WD Photos app installed (2.4.5). Can you also share what iOS version you have installed on the iPad? 

WD Photos is up to date, and IOS is version 8.1.2. It displays, then TV goes completely black. Honestly, it is all we wanted Apple TV for. I can’t understand what is causing it… IPad? Apple TV? WD? Everything else displays, including WD My Cloud.

Did you set the iPad or App to AirPlay to the ATV by chance?

Thank you for your interest. The iPad is set to AirPlay, with mirroring on. We tried it on my wife’s iPad, (2nd Gen) and the same black screen. This only happens with WD Photos.