WD Photos and WD2GO Pro iPhone app-wireless connectivity issue

Hi folks, hoping someone can advise what to do. I can’t log onto My WD BOOK Live Duo using WD iphone apps. 3G connection is working every time, but wireless seems to be an issue. Same thing is happening with iPhone4 or iPad3.

Which leads me to conclusion-I need to add somehow these apps onto my router settings in order to make wireless access work!? I have Netgear WNDR3700 router.

Thank you in advance people!

What happens when you connect via wireless?

It should make no difference 

either WD photos in not connected to internet or Device is offline (for WD2GO app)

I can’t connect wirelessly on my home network ONLY. Work wireless network is fine.

Sounds like your router is preventing WiFi clients from accessing Wired clients.

What to do then? Has to be some router settings that I can apply!?

Note that some other ipad/iphone apps can access network drive with no issues. In fact, only issue is with WD iphone /iPAd apps

Try switching your My Book Live to a Relay connection instead. It forces communication through our servers first, so it should work for users with routers that segregate wired/wireless.

Dashboard > Remote Access > Configure > Connection Options

Choose “Manual” in the drop-down

Enter ports that you do NOT add in the Router instead of 80/443

So basically, just to keep default manual settings on Live Duo and don’t touch router?

Thank you for your reply.

Hi Laura, it worked! I had to wait approx 1min before I could connect successfully, but it’s OK now.


Now I have another issue-WD photos is not refreshing. I would add pics and WD2GO pro app will “see” those pics but WD photos will not. I tried everything (advices here on forums, knowledge base etc).

Any advice that you can share guys?

First Time on community. I had my book live working with wd2go since I did the last firmware update late September. I have reset my book.  I still can’t get on my cell phone or Ipad . cell phone I getting network connection error 904 .Ipad just spins.

I not sure if my router  is set up correctly  (Belkin ND600) I am totally lost If anybody could get me in the right direction

Note: no matter what my settings are in my router, My book live connects stays at Connected port forward establish, I am not that computer smart, but I was able to getting working before firmware update  any assistance would be greatly appreciated

i was able to figure it. once i took FTP I was able to connect thru my phone and Ipad

glad to know is sorted dude