WD Passport USB 3 not working - my solution

This is not a BS solution, like making you buy a hub or another cable, this is a proper fix.

Like many others on this board, my Passport stopped working in my USB 3 ports, and only worked with USB 2. After many months re-installing drivers, trying different drivers, etc, I came across this thread:


It said to adjust the PCI-E Frequency and set it to 100 instead of any other value (ie, 101). It has something to do with overclocking and WD drives not having any tolerance for it. I don’t overclock my PC, but I had a hunch that the “Optimal” BIOS settings for my Asus motherboard were actually slightly overclocking my PC.

I tried to find a BIOS option that looked like the one in that thread and I found this:

“BCLK/PEG Frequency” and it was set to 103.5 or something.

According to my motherboard manual, this option allows you to overclock the CPU and VGA. I never touched this, so I think it was set automatically by my BIOS when I chose the Optimal Configuration. I changed it to 100 and reset the PC.

What do you know, my Passport drive works with USB 3 again. Welcome back, you **bleep**. After all that headache and zero input from WD, I finally have the drive working how it should. Once again, thanks for nothing WD.

1 Like

Cool, thanks for sharing.