WD Passport Ultra On the Fritz

I’ve tried to read all the forums here about this issue, but it seems that many are not experiencing my exact problem.

I’ve had My Passport Ultra for around two years now. It has always worked on my system:

Dell Inspiron 7559
Intel® Core™ i7-6700HQ CPU@ 2.60 GHz
8.00 GB Ram
64 - bit

Recently when I plug it in to transfer data it turns on. I can see the light and I can feel it vibrating, but my computer will recognize it and then eject it, recognize and then eject it in a constant loop. It is not available long enough for it to be recognized by WD smartware, windows explorer, or disk management. However, I did see it going on and off in the device manager. It would recognize it as a passport ultra for around 3 seconds and then it would act as if it were ejected.

I have tested it out on another computer, and it works perfectly.

I have tried to do the tests mentioned in other forums, but my drive is not recognized long enough for me to run these tests. I cannot use smartware, I cannot change the letter of the drive, I cannot allocate the drive in disk management.

If there are any other solutions please let me know.

Thank you.

Hi Sknim,

As WD Passport Ultra drive is working perfectly on another computer, this issue may be caused by the USB interface. I would recommend trying to check drive by connecting to another USB interface on the computer.

Thank you Brandon.

I have tried all of the ports. They all react similarly to the drive. They don’t recognize it, and if they do it is only for a second.