WD Passport Ultra hangs when unlocked, pops up after "Cable test" part in DLT, still freezes after test

WD My Passport Ultra, few months old. Works fine most of the time.

But now for the second time my PC will not recognize it (last time was probably about a month ago). Last time hooking it up to my laptop “unlocked” whatever was wrong on my PC, but I think it should not happen with an external HD.

No problem when I plug it in. When I unlock the drive it completely freezes Windows 7. When I unplug it, Windows comes to life. So It’s definitely the drive.

Starting DLT it shows a question mark for SMART status. If I run a test, after it does the cable test part it pops up with the “what do you want to do” window.
When the test is finished and I close the test window, it shows the SMART status as PASS. And subsequently if freezes Windows again.

And no, changing USB ports doesn’t work.

So what is going on here and how can I (or WDC) fix this!

EDIT: Laptop also hangs when unlocking the drive…

First you should run Drive Tests on WD My Passport to check for the health. If drive passes, check after the reformat of drive, otherwise need to check for the replacement under warranty time.

After more tests I believe there is a problem with a certain type of disk corruption in combination with the motherboard chip (and maybe in combination with the controller WD uses).

My W7 work PC as well as a colleagues W10 PC (both with a GigaByte motherboard) as well as my work W7 Dell laptop hang when I unlock the drive.

But my home Toshiba W10 laptop has no problems with the device. If I run a checkdisk from my laptop it is then accessible on all other devices again.