WD Passport Ultra - Corrupted by Snap Deploy

So we use passport ultras for storing windows 7 images and use Acronis Snap Deploy to deploy those images.

Recently I used the Snap Deploy 5 CD to reimage a machine, and once I selected the .tib image file to deploy, it said it was corrupted and now the Ultra is not recognized by windows. I can see it in hardware manager, but under disk management it just shows as totally allocated.

Does this mean the data is lost? I find it hard to believe Acronis would just automatically wipe the entire drive because of some error. I also understand people asking ‘Why don’t you go ask Acronis since it was their software that messed it up?’.

I’m not worried about why it happened as much as I am getting the data from the drive back. Is it possible?

Things I’ve tried:

-There is no ‘assign drive letter’ to that disk like so many online guides seem to think helps’
-I can create a volume on it, but I have to format it to use it and I don’t want to lose the data
-Tried using that one wizard (I forget the program name) to partition it but to no avail

any way to get the data back? I ran the WD drive scan on it and it seemed to be fine.


You mean un-allocated?

As a recommendation, try using a data recovery software to see if the drive shows up with the data.

If you repartitioned it your data is likely lost. You must never partition a drive that is already partitioned unless it’s to add another partition to unused space. You cannot re-partition an area containing data without losing the data.

If you really knew what you were doing you could use a disk editor to rebuild a partition without data loss. For the average user there is a steep learning curve to learn how to do that but it depends how badly one want the data.

There are programs that will do a direct scan of the surface, identifying files based on a data signature common to certain files. It’s really hit or miss.