WD Passport ticking

Hi guys,

I have a WDBAAA3200ABK external drive and It’s ticking… I’ve tried many settings in OS (Windows 7), changed cable, buyed USB hub, and still no success - ticking doesn’t stop !!!

Sometimes It does work when I plug It directly to the computer in the back (to motherboard), but It takes time to recognizes it…

I’ve also tried on may other computers and drive works perfectly :manfrustrated: !!!

First I thought that it’s some OS Windows issue, because everything worked O.K. on XP, until I installed WIN 7 :crying_cat_face:

But now, after many attempts to solve the problem with software solutions, I dug up into my PC to see if I missed something about hardware - AND I HAVE COME TO BRAND NEW IDEA !!!

Obviously drive doesn’t receive enough power to spin the disk, and I’ve noticed that my power supply is not as high as my graphic card requires It !!!..So, I’m thinking  - If graphic card needs that kind of power, maybe there is no power left for other devices to work ???

According to system requirements, power supply should be at least 450W (reccomended 500W), and I have only 430W :robotsurprised:

So, Now I’m looking to buy a new power supply (at least 600 Watts), but before I go for my new purchase, I’m asking all of you out there - -


P.S. : Otherwise, PC works fine, games played with this power supply wtih no problems !!!

Thanks for your help !!!

Yes, if the passport is not receiving enough power you might hear a clicking sound. Try connecting the passport to another Laptop/PC and check if it works.

I HAVE tried already, I also written that in the post, drive WORKS PERFECTLY on every other PC/laptops !!!

Sorry, didn’t notice that part :stuck_out_tongue:. Another option you can try is to get a USB power booster cable, it will use two USB ports on your PC but it should give enough power to make the HDD work fine. Call tech support and see if they can get you one for free.


Thanks, I will try that, I hope this works !!

If it will, then I’ll let you know and click as solution :slight_smile:

Thanks again !!