WD Passport pauses while deleting erasing drive

Hi Everyone!!

I recently found my older WD Passport 0748 1TB. I know there’s nothing on it that I need so I’m just trying to erase it all. Heres all the info I got;

  1. It doesn’t show up in Disk Utility or Finder
  2. I’ve tried three different USB cables, tried both my usb ports
  3. Its says it’s locked when I try and load a new driver, I don’t know the password
  4. It shows up in WD Drive Utilities which it where I’m trying to erase it
  5. I’m using High Sierra
  6. The drive is blinking, no solid light
  7. Nothing happens when I press any of the diagnose buttons in WD Drive Utilities
  8. When I start erasing, the bar gets to around 55% and then just stops moving.

I think that’s everything. Anyone ever run into this issue? Know how to fix it? For anyone that has erased it how long does it take? It went 0-55% in 20 seconds and now it hasn’t moved in over an hour.
Any help will me greatly appreciated, thanks!

Hello skeletonskeleto,

Have you setup the security on the device using WD Smartware or WD Security in the past?

Nope as far back as I can recall I never set one up. Is there a way I can bypass it and just start fresh?>