WD Passport not visible in Windows Explorer


My WD passport (1TB) USB 3.0 was removed from my laptop while it was unzipping files. It’s now not visible within Windows (Win 7 & Vista) explorer. Within  Device manager the drive is visible as ‘disk drive’. When I connect the HD to the laptop it  try to load the driver but fails. It then says that the drive needs to be formatted to be used.

I have a lot of family photos which I don’t want to lose so any suggestions on how to recover the drive?

I’ve installed the SES driver & tried updating the  driver but it believes the currently installed is the best driver.

I ran the WD tool but after 40 minutes of the quick test it hadn’t done anything so I unplugged it.

Any help much appreciated. 


I managed to assign a drive letter to the WD passport via Disk management & I was able to access all my files on the USB drive. I started to copy files off but it crashed out after about 30 minutes. I did manage to recover some file though & I’m glad that they are still available on the drive.

The problem is that I can’t get the drive to appear again.

When it’s connected I can see the drive via Disk management but get this error when trying to assign it a drive letter “the operation failed to complete because the disk management console view is not up-to-date. Refresh the view by using the refresh task. If the problem persists close the Disk Management console, then restart Disk Management or restart the computer” needless to say restarting doesn’t work. I can’t assign a drive letter via Diskpart either.

I’ve created a Linux USB drive but I’m unsure what to do next. Would recovery software help at this stage?
Any help much appreciated. 

I had a similar issue.  I updated my WD driver recently now I can see the drive with unlocker just fine but when I unlock it that’s all I can see, no passport drive.  I’ve tried unlocking it again and it says that it’s already unlocked.  The files are still there since the drive works perfectly on a different laptop that hasn’t been updated (and certainly won’t be now!).  Also tried a similar passport on the first computer and it works normally.  This all seems very weird to me.  Tried updating my drivers but I’m told that I’m completely up to date.  Very frustrating. Any suggestions would be appreciated.