WD Passport Not Recognized By My Computer and Then Data Seem To Be Petitioned Off from Access


#1

Dear Support,

I have purchased a WD Passport drive (deleted) that was puchased about half a year ago. I stored a lot of data in there as a back up and recently tried to retrieve these data but somehow my computer no longer recognize it. After searching for a solution on the web, I went to the diskmanagement and tried to manually assign a drive letter to the WD drive to make the computer recognize it. However, the data seem to be somehow petitioned off on a seperate sector of my WD Passport drive and off from any access.

When I go to “My Computer”, I see the original drive is now labeled as “SYSTEM RESERVED (Z:)”. This drive seems to exist no matter I connect my WD Passport or not. When I DO connect WD Passport to my computer, the white light blinks and it seems to be spinning, but nothing shows under “My Computer”. The "“SYSTEM RESERVED (Z:)” is empty, but when looking at Disk Properties, it has 70% free space availble and it has 30% of space used that cannot be accessed.

My questions are as below

  1. Why there’s a disk “Z” that seems to be available no matter I connect WD Passport or not?

  2. How can I retrieve my data from WD Passport? I have some important data stored on there and I’m extremely afraid to loose them.

I’m attaching a snap shot of the drive herein.

Thanks a bunch

WD.jpg


#2

I would suggest you contact a data recovery company for retreival of the data

http://support.wdc.com/recovery/index.asp?wdc_lang=en


#3

Thank you for you reply and I’d prefer using a data recovery service as a last resort and in addition, since the drive is still under warranty WDC should compensate me for the recovery service. Anybody who has any other better suggestions?


#4

So, the drive shows up in Disk Management, but not in My Computer?  Does it show up as one partition in Disk Management?  What color is the bar in Disk Management - black or blue?

Edit

If the drive does not show up in My Computer, how are you able to see it’s properties?