WD Passport essential - no file access, drive is unallocated, drive is pasword locked


#1

I am working on a friends 320GB Passport Essential. She lost access to her files and is very upset. They are all files for her business.

Here is what I know:

  1. The only thing that shows up in Windows Explorer is the drive labelled WD Smartware

  2. When you run the smartware utility it says the drive is locked. She stated (and confirmed later) that she never set a password ever.

  3. When I look in disk management, it shows the E. drive (WMSmartware drive), and also shows 297GB of unallocated space. It also shows the disk as Not Initialized.

I have tried many recovery programs to get to her files, and they either cannot see the drive at all, or do not find any files.

What I would like to know is why it set a password to her drive, why is the drive show as unallocated space, and what procedure can I do to recover these files for her.

I called WD today and they were no help at all. All he kept saying to me was that if I type in the incorrect password more than 5 times it will ask me to reformat. I finally told him I know because he had told me at least 15 times in the last few minutes. He told me that they can do HDD recovery, but couldn’t tell me anything else about it.

My friend is so upset about this that she has already said she won’t buy another one of these again, and really is leary about sending them her drive to recover.

Has anyone gotten this problem solved? Has anyone used WD to recover files from their drives?