WD Passport drive - won't unlock on HP Pavilion Windows 8.1 - solved

I couldn’t get my WD passport drive to unlock on my new HP Pavilion laptop running Windows 8.1

It would recognise the drive, I could even explore the ‘unlock’ files and folders so I knew the cable and USB port were working correctly - but everytime I ran the unlock software, it can back with an error message screen telling me to use … the unlock software to unlock the drive!  Very annoying.  I even tried changing the drive letter of the ‘unlock’ software partition, and installing various updates from WD but nothing worked.

But it’s a simple fix.

I had used some Cyberlink software that came with the laptop to try and burn some files to a CD but had never burnt them - but this left a ‘virtual’ drive on the laptop with the letter F.  When I ran the WD unlock software, it tried to mount the unlocked drive using letter F - when it found it already in use, it just gave up and told me to use the ‘unlock’ software to unlock the drive.

So I right clicked on the virtual partition created by the Cyberlink software (containing the files I originally wanted to burn) and  deleted / cleared / unmounted the drive (I can’t remember exactly what I did but I used the Cyberlink software to remove this virtual partition). 

And once that had gone, everything works like normal.


Thanks for sharing this with the community.

Hope this helps other users presenting the same issue.