WD Passport doesn't see data on computer hard drive or passport drive

I have a WD My Passport that I’ve used for months now to backup data from my computer’s hard drive. Up until now it has worked fine (as least I thought it was working fine.)

Today a serious problem appeared. When I plugged it in, the computer recognizes the Passport drive okay, and I’m able to open the WD software, BUT when I go to the “Backup” tab, both drives appear in the two columnar boxes, but BOTH Data for Backup and Data Backed Up said “files backed up- 0, size- 0.00.” The Passport drive is not only saying there’s nothing backed up on it, but it’s not seeing the data on my computer’s hard drive that needs to be backed up. It seems to be saying both drives are empty. I don’t know where to begin to solve this problem.

The computer is working fine, i.e., I’m not in one of those desperate situations where I MUST retrieve what is on the Passport, but I’m disturbed that everything I thought was backed up ISN’T.

I’d like a diagnosis and some advice, if possible, because I’m curious and would like to avoid this problem in the future, but I don’t trust this drive anymore and I’m going to buy a new one tomorrow. Thanks. 


Windows 7 - 64-bit

this is just a problem with the software must likely

go in to the drive to verify the files are there

uninstall the software and download the latest version

Thanks for the reply. I installed the update and it seems to have caused a problem. When I restarted the computer, it took 15 minutes to boot up. Then everything was insanely slow. When I plugged the WD drive in, the window never did open. I’ve rebooted, tried different things. Now uninstalling all WD software. Ordered another different brand drive from amazon. I have owned two other WD external drives and had problems with both of them. Thanks for your help. :slight_smile: