WD Passport disconnects on Macbook but not PC/PS3

I have a Western Digital 1TB Passport USB 3.0 External hard drive which I have been using happily for over a year. However recently it has started disconnecting from my Macbook randomly giving the message “The disk was not ejected properly”.

Now I am aware there is an ongoing issue with this, however none of the other responses seems to quite match my problem I am having - let me explain:

I have realised that every time it disconnects, I have moved the hard drive slightly. After extensive testing, I have narrowed it down to it being the USB end attached to the hard drive, not the end plugged into the laptop. (For one, its a brand new retina macbook - only a month old)

Sometimes I plug the hard drive in and it doesn’t even register. When it does register I have to keep the hard drive USB socket completely still. The slightest movement can result in a disconnect from the computer. Sometimes I can keep wiggling the cable and it will then reconnect. In other words, there doesn’t seem to be any one position in which it always connects or disconnects, rather the position is random, and once I’ve found it I must not move the cable from that position.

Now the annoying thing is that this is not the case when I connect it to a windows laptop or a PS3. I can wiggle the cable all I like and it will not eject the hard drive at all. This seems counter-intuitive to me. All evidence points towards it being a dodgy USB connection BUT, only when connected to a macbook?? Essentially, the connection only becomes super sensitive when plugged into MY laptop. More recently, I even tried it on my friend’s macbook pro (non-retina) and it worked fine then, no disconnects.

The only thing I believed likely to be the case was the hard drive drawing too much power from Spotlight indexing its contents. This made sense to me as the hard drive has filled up over time so would require more indexing, it must have recently reached the threshold power requirements??. It would also explain why other devices were not affected. However, I tried putting the hard drive into the ‘no-index’ box under system prefs but this did nothing to help the problem.

The hard drive has been partitioned and formatted into a Time Machine section (200GB), and a FAT32 storage section (800GB). Don’t know if that’s relevant or not but there we go.

Any ideas as to what would cause this, how to fix it, and why the PC/PS3 doesn’t experience this issue? Or even my friend’s non retina macbook pro?



This User had a similar issue. Please see if this will help: 


I have the same issue with my 15" Retina Macbook Pro and my 2TB USB3 Western Digital Passport. However its only the right port that disconnects my external drive. Sometimes it will work for minutes and sometimes it disconnects in seconds.

The left port though has no issues with it all. My right USB port on my Macbook Pro retina has also disconnected my card reader which is USB2. However the right port will NEVER disconnect my Seagate USB3 external drive that has a AC power adapter and it will never disconnect my USB2 western digital 160gb portable drive.

Go figure…

Western Digital did release a firmware update addressing USB issues on the Mac however that didn’t fix my problem. Seagate also did a firmware update on the same issue which did fix many people including mine for that drive. I would try the other port you got to see if that works any better. If not I’d try and return it and get another drive or get a USB3 hub that has an AC wall power adapter.

EDIT: I should also note that wiggling my USB 3 western digital passport drive on the right  port disconnects the drive as well like you but not on my left usb 3 port. I have read the USB port closes to the screen on Macs share the BUS with the facetime camera, bluetooth and keyboard which can cause power fluctuations on that port.