WD P/Port Not Showing Up


I’ve been using a 500gb WD My Passport Hard Drive For 8 months now. Today my laptop was having problems, and after waiting 20 minutes for it to shut down (Was showing the “logging off” screen for said time) I shut it down by holding down the shut down button, while the P/Port was plugged in. Now when plugged in, Windows makes the “Hardware inserted” noise, and the little light on the P/Port comes up, however it makes a “whining” noise for a few seconds, and doesn’t vibrate, which it normally does when plugged in, and it doesn’t show up in My Computer, device manager, devices or printers, etc.  I have tried it in all USB Ports on my laptop, and still nothing comes up, I also tried it in my parent’s laptop, same situation, the P/Port “whines” but isn’t recognized. 

This is really frustrating as a film project I have been working on for three years is stored on the P/Port. I have never experienced problems like this at all, and would really appreciate some feedback. I’m totally OK with buying a new lead or something. 

Laptop Specs Below.




Hewlett-Packard G72 Notebook PC, with Windows 7 Home Prem. 64bit Operating System


have you try to connect your drive in a different computer? If no, please do so anf let us know if the drive is recognize.

Hi, yes I’ve tried two different computers, and nothing has happened, it isn’t recognised at all.

I’ve made a recording of the noise it makes, as I had a look online and it said the noise could help with the problem. It’s  here, but its pretty quiet.


Just to let you know, I tried a new cable, and the “freezer trick” today. Still no response. 

One interesting thing though, was that I uninstalled the drivers, restarted it, and then plugged it back in. It reinstalled the drivers, which means its not totally dead, but didnt pop up anywhere.