WD N900 Random connection issues

Bought a WD N900 recently and have been having mixed results with it.

I did install the latest firmware and most settings have been left to Default except for FastTrack and QoS that I had to turn off because they were causing the same issues as some other users have reported: (Slow browsing or unable to access many websites)  For the fact, I’m also an owner of a Sympatico SpeedStream DSL modem.

Now, here’s the main problem I have now…  The N900 seems to randomly stop providing internet access to the connected devices. This usually happens a couple days after I power it off and reboot it. When it occurs, I can’t browse to any websites anymore but the very odd thing is that any active downloads will still continue and complete properly.

Rebooting the device fixes the problem but doing that every couple days is very annoying, especially considering the price I paid for this router, I expect it to work all the time.

I’ve been supporting WD for many years and I don’t want to have to return this to the store.

Any help or advice would be highly appreciated.

Definitely a weird problem

have you try using the network diagnostic tool and see what error comes out?

What happens when you use the ping command?

Can you post a screen of the IP config page?

I haven’t tried the diagnostic tool or ping yet but I will when the problem re-occurs.

Here’s the config I’m using:

Modem: Bell Sympatico Speedstream 5200

WD N900 Firmware version 1.03.11

Internet Connection Type:   PPPoE

Address Mode:   Dynamic IP

Reconnect Mode:   Always on

Maximum Idle Time:   0

DNS Mode:   Receive DNS from ISP

Primary DNS Server:   (blank)

MTU:   1492

MAC Address:   (blank)

Enable DNS Relay:   ON

Enable DHCP Server:   ON

DHCP Lease Time:   16800


IPSec (VPN):   OFF


FasTrack Plus QoS:   OFF

Set Uplink Speed at:   724 Kbps

Automatic Prioritization:   OFF

Enable Enhanced WMM:   ON

Enable UPnP IGD:   ON

Device Mode:   Router Mode

Thanks for the help…

Also experieincing this/similar issue: dropping wired connections several times a day. About 3/4 the time I’m losing connection to the router itself from wired devices; occasionally the connection appears to still be valid, but no internet connection. Wireless devices are not affected. Firmware Version 1.05.12

1 Like

I’m getting connection drops to my VPN and VoiP multiple times per/hr.  QOS disabled.  Firmware Version 1.05.12

My experiences are the opposite. I have my wireless devices lose their connection to the internet but can access other devices on the network and the N900. My wired devices have no problem. My last attempt at solving this had me streaming Netflix on the Xbox with a wired connection while browsing the internet on my laptop wirelessly. Xbox never experienced any drops but the laptop would frequently drop out.

I need to boot up the old desktop and see if I experience the same problems.


Can you try accessing https://wellsfargo.com or some other https site? This will see if port 80 has a problem. Reason why I’m asking is because your download does not stop.

If you can access https, can you RESET your router to default factory ?

If the issue still exists, please provide log file by following below instruction:

  1. logon to Router UI

  2. Advanced settings

  3. Admin

  4. Log

I discovered the same problem with the Enable DNS Relay but my problem was triggered by adding a laptop to my home network. I have a laptop that I bring home from work. Everytime I connected the laptop to my home network all devices, wired and wireless, would loose internet connectivity however any active sessions would continue to work.

I worked on this problem for over 2 weeks and finally discovered that when I turned of the “Enable DNS Relay”, I could connect the laptop and not experience any issues. I am guessing that some setup on my laptop is triggering the event but I don’t know what it is and would appreciate any feedback. Note; if I booted that laptop into Windows 7 safe mode with networking, I could connect it to the network and not experience the problems.

I am also having serious seemingly wireless only connection issues.  It seems to drop wireless connections at least twice a day now.  It was working well for a bit, but now everyday the wireless connections are no longer available.  The only recent changes are that I added a new ipad to the wireless mix.  I can’t believe this expensive device doesn’t seem to be working correctly after such a short period of time.

What are the best troubleshooting optons here?  I really do like being able to access my pictures on the network, but really cannot live with constantly having to log into the router (hardwired) and resetting the wireless portion of it.  It seems if I disable and re-enable the guest wireless it works again.  This was the only way I could get the ipads to connect.


Tech support says to “clone your mac address” as a first step, then call back if it doesn’t work and you will go to tier 2 for advanced trouble shooting.


Have you tried to cool the router down?