WD MyWorldBook 4TB (2x2) keeps disappearing/rebooting

I have the WDMWB 4TB (2x2TB) white edition, which is getting on my nerves recently. Bought almost 4 years ago, it has worked more or less satisfactory for about 2 years (striping for maximum storage area) as a movie/music/picture server. Twonky is essential in order for the device to be used by my PS3, so it is actively sharing videos, music and pictures folders. Same folders are shared as mounted drives for the PCs in my home network. Device is directly connected to a Gbit port on my Cisco switch, as are all other devices (Cisco 16port Gbit switch).

However in the last year or so, it keeps rebooting/disappearing after continuous use. For example yesterday I tried to watch a movie (through my HTPC and VLC), and it “disappeared” 4 times in total. It appears as though it is reseting, and it takes about 2 minutes for it to come back. Same behaviour when used through Twonky, in which case it takes even longer for it to become available again (since it needs to rebuild the whole database). Sometimes it won’t even rebuild, and it will just stay there saying that it needs a reset (in the Status page).

After reading all relevant threads in here, I have left only FTP and Twonky active, all other services and processes are disabled, however problem still remains.

Does it sound like a hardware problem (network, power supply ?), or maybe someone has some other ideas or solution ?

As a troubleshooting step try connecting the My book power cable directly to the wall, if the problem continues, you can call tech support for a replacement.