WD MyPassport Ultra 2TB with ultra slow data transfer

At first, sorry for my writing, I´m not a native speaker…

The troublemaker is my external harddrive (WesternDigital MyPassport Ultra
2TB) . Several weeks ago I interrupted accidently the
data transfer, after that Windows 10 asked for fixing, but I couldn´t finish the
repair process, but the ehd worked fine and I had complete access to my data.
Then I dropped it, but it worked in the beginning, than suspended while opening
a file. After rebooting, windows couldn´t detect the drive, no drive letter.
When I tried to assign a new drive letter Windows told me there is an I/O
device error.

Some days ago I tried again my luck with recovering the lost data and I saw
that the ehd now has a drive letter. I tried to copy a 1gb file but it was really
slow, data transfer rate was only beetween 350-750 kb/s and it failed after
coping at 35%.

I did try a different data cable for the external harddrive and on a
different pc without any improvements. Also tried to get access via recovery
software like “testdisk” and “recuva” but the problem was
always the slow data transfer rate as mentioned above. The drivers are uptodate, I rebooted Windows and also the WD support software.

Do you guys have any idea what can get me the data back? Anybody with experiences on swapping the pcb (I have no guarantee anymore)?

Thanks for any help!


Sorry to hear that. Sounds like the unit got some physical damage when you dropped. As a recommendation, contact a professional data recovery company to see if they can open the drive and get the data.

Thanks for your reply!!!