WD MyPassport Pro Wi-Fi: how add as network drive in Windows?

Have you tried this? It looks really nice, but how to tell if it’s legit or not? I guess all I’ve got to loose is $35.

Hi Vimb, without your precious help I’d be so frustrated with this sleek piece of equipment - got myself the 4TB MPW Pro. I found a few other flaws (for instance, it doesn’t automatically reconnect to saved SSID and once you manually make it you lose a bit of control over it; wireless connectivity drops if plugged in) but overall it’s not too bad. Not sure if it was worth €220 but glad the hardware at least supports SMBv2. I wanted to make an exfat partition too but given the circumstances I guess I’ll dedicate a separate unit for that purpose. Last but not the least, if for whatever reasons you’re not using Linux, you can use the built-in Windows SSH client or use third-party such as PuTTy or WinSCP.
Thanks a lot again and couldn’t agree more on the below:

Ciao :grinning:

Dear all,

can someone share the content of the smb.conf and smb-global.conf that are working, please? I tried to get it running with the latest firmware version of the WDC wireless SSD with 2TB without any success.

Following options for SMB have been tried so far:

  1. max protocol = SMB2 in the smb-global.conf
  2. max protocol = SMB2 in the smb-global.conf and smb.conf
  3. min protocol = SMB2 in the smb-global.conf
  4. min protocol = SMB2 in the smb-global.conf and smb.conf

the device has been rebooted after each change.

As user I tried to connect with admin and root with the configured password for admin / root access. Which user has to be provided for SMB access?

Additionally I have logged an incident with WDC support. As answer they are recommending to use SMB1 what is not an option. See for further details: https://support-en.wd.com/app/answers/detail/a_id/24800

… update…

My config files look as follows and with these settings I can see the device in the network environment of my private Win10 Enterprise 19 09. But I still fail to connect to the share with user and password. Any ideas what should be used?

[root@MyPassport samba]# more smb-global.conf
max log size = 50
security = user
map to guest = Bad user
encrypt passwords = yes
smb passwd file = /etc/samba/smbpasswd
passdb backend = smbpasswd
log file = /var/log/samba/log.smbd
socket options = TCP_NODELAY SO_RCVBUF=2048000 SO_SNDBUF=2048000 IPTOS_LOWDELAY SO_KEEPALIVE
use sendfile = yes
min receivefile size = 0
delete veto files = yes

idmap uid = xxxxxxxxxxxxx-xxxxxxxxxxxxxx
idmap gid = xxxxxxxxxxxxx-xxxxxxxxxxxxxx
template shell = /bin/false
winbind use default domain = no

veto files = /.bin/.AppleDesktop/Network Trash Folder/.twonkymedia/.wd-alert/.wdmc/.wdcache/.USB/.wdmtp/
create mask = 0777
force create mode = 0777
security mask = 000
force security mode = 777
directory mask = 0777
force directory mode = 0777
directory security mask = 000
force directory security mode = 777
min protocol = SMB2
max protocol = SMB3
[root@MyPassport samba]# more smb.conf
#======================= Global Settings =====================================
[global]
workgroup = WORKGROUP
server string = MyPassport Wireless Pro
netbios name = MyPassport

min protocol = SMB2
max protocol = SMB3

include = /etc/samba/smb-global.conf
include = /etc/samba/smb-shares.conf
[root@MyPassport samba]#

thanks and best regards DBA73

Sooo. . . inspired by a few recent threads on this topic. . .

. . . .I brushed up on my SSH commands and hacked into my MPWP. (HDD version).

. . . .I tried adding the min/max protocol lines to the configuration files. . . .and I lost access to the files from my win10 machine. (I could still get to the WebUI and SSH into the device)

I ended up deleting those lines

min protocol = SMB2
max protocol = SMB3

and everything started working again (well, worked as before).

Can you please post a screen shot. I have the same issue. I CAN connect to the wireless device, and the media server works, but anytime I try to connect to the device wirelessly to access it’s file system, you know, my files? I just get to the user interface page of the mypassport server. Just the standard 192.168.60.1 interface. Obvoisly not what I want.
The device does show up in file explorer as “storage” but click on that and you get the user interface.
What is the address to map the network drive? the address to the file system?

Use “forward” slashes instead of “Back” slashes in the file explorer address bar

You’re right, you’re not a WD expert. You are, however, a jackass. In every single post I have seen from you, you are one of the most condescending jerks I have ever encountered. You said to the OP “I have done all I can to help you.” after telling him “I just don’t believe you really know what you are doing. . .” Here is the reality. People ask for help and you come along and offer vague explanations of how to do something and claim you’ve done exactly what they’re asking for and direct them to the manual. But you never really offer any explanation that is helpful. Instead, you get frustrated because you believe they are dumber than you and impossible to teach. YOU are the problem here, not the original posters. In the amount of time that you spend with your initial response, commenting on telling them to just go to the manual and find everything they need, then calling them stupid in one way or another, you could just as easily give clear, step by step instructions on how you did something the manual doesn’t lay out clearly.

You act like you’re superior because you have “TWO MPWs set up this way” but allow me to tell you something in plain English so your bullheaded brain can understand it: You have offered nothing in terms of help on how to access this drive through Explorer. I actually have read the manual and I have attempted to do the vague setup as you’ve “explained” it. When I try to access the driver, it takes me to a Twonky NMC webpage. The attempt is to access this directly through our computers without being rerouted to an external method of data sharing. If you have figured out how to do this, then please educate us on how to do that. Otherwise, sit down, shut up, and allow others to provide actual help.

Did you really post a complaint about a user not seen for YEARS in a thread that hasn’t seen a post in 7 months?

In a way, I guess I did. The post was more for me trying to get help fixing this issue. I still cannot get mine connected to use as a wireless drive because it takes me to a webpage for media instead of opening a folder on the drive. In the process, all I saw was that guy being and absolute bully on this and every other post in the forum. Not everyone is well versed in this sort of technology. I am a civil engineer, not a software engineer. These things are foreign to me as they are to most people needing this sort of help. A vast majority of us need clear, step by step instructions on how to set something up like this but that isn’t what I found. You (not you directly) can give someone an answer without being completely condescending with it. That’s childish, high school bullying and uncalled for.

In regards to him being someone who “hasn’t been seen for YEARS in a thread”, I do not live on this or any other website. I found this site trying to fix my issue and have looked at a handful of posts trying to figure it out. That does not tell me if someone is active on a site or not.

Ok - - -If I understand correctly, you want to know how to access the file system on a MPWP.

The way I do it is through Windows File Explorer.

Pro-tip: The device won’t necessarily show up as a network drive the way it should as a “computer” in the network section of file explorer.
It will show up as a “Storage”, “media device”, or “Computer”.
If you click on storage; you get the Dashboard.
If you click on “media device”; you get the twonky page.
If you click on “Computer”; you get the file folder system.

The problem; as I said; is that MPWP won’t necessarily show up as a “Computer” the way it should. This is a flaw in all WD OS/3 era devices. (Fixed in OS/5 - - → But these devices can’t run OS/5)
Some say it’s a master-browser issue. Some say it’s because SMB1 is not running (It’s deprecated) in Windoz (but you can still load it through “windows options”)

To access the drive; I type the ip address of the WDWP into the address bar of file explorer. (NOT a web browser; use file explorer). It also works if you type in the device name in the address bar.

Let’s say you are on the WDWP Network that the device generates.
Let’s say the ip address is 192.168.60.1 (this is the WD Default address for the device)

If you type “//192.168.60.1” you will get the device dashboard.
If you type “\\192.168.60.1” you will get the files; just like any other network drive.

(The difference is the slashes; and I may have this reversed)

NOTE1: You can set up the device to log into your home network through the “WiFi” tab of the dashboard. Once connected, you can click on the network, and a pop-up appears. If you click “Share content on this network”; THEN YOU CAN LOG INTO THE DEVICE FROM ANY DEVICE ON YOUR HOME NETWORK

NOTE2: If you connecting to the device from your home network; and you are “sharing content”; then you access the drive via the IP address (or device name) assigned by your router.

NOTE3: You can change the device name in the “Admin Tab” of the dashboard.

NOTE4: The HDD and the SD card will show up as seperate shares on the drive

PROTIP: I assign a permanent IP address to the device FROM THE ROUTER. That makes things easier if the IP address isn’t ever changing. Then you could even map it as a network drive. I NEVER fix the ip address from the device; because if you change routers. . .then you might lose access.

You friggin’ genius, you. That got it!!! I have been trying to set this up for two years and inevitably I get frustrated, give up, and plug it directly to my laptop to use as a hard drive. I have now mapped this as a network drive. I cannot thank you enough!!!