WD MyPassport Pro Wi-Fi: how add as network drive in Windows?


#21

No. Do NOT enable SMB 1 server unless you have very old Windows instances that can’t do SMB 2 and are using it to connect to your PC files on a network. If everyone is running at least Windows 7, you have no need to enable SMB 1 as a server. A client? Yes. But a server opens you up for potential vulnerability.


#22

Hi valerun. I’m struggling with this issue. Could you please detail exactly what you typed in the Windows Explorer? I tried \IP\Storage and other combinations and in all cases I get a “No access” error.

Are you using the WD device wifi or your own wifi for the connection?

Thanks in advance!


#23

\YOUR DRIVE IP\Storage

Worked for me.


#24

The MPW own wifi is a sealed system and cannot be part of any other network, You need to connect the MPW wifi to the home network/wifi, then you access the MPW through the home SSID and NOT the unique device wifi. SEE THE USER MANUAL. When I do this the MPW can be seen in Win FE under “Network” as any other device on home network.


#25

Thanks! Yes, it finally worked for me, but I had to enable SMBv1 compatibility.


#26

It works on both a Win 7 and 10 for me, and no SMB concerns.


#27

The MPW Pro by default will connect just fine to Win7 and Win10 machines that were upgraded from Win7, but not on any clean, secure new Win10 machines.

The advice to enable SMB1 support on your Windows 10 machines, while technically works, is inconvenient. Instead if you are comfortable with Linux, you can pretty easily enable SMB2 support right on your MPW Pro and have it just work with any Win10 machine.

Here are the steps:

  1. In the MPW Pro Admin screen, toggle SSH access to “On” and set a root password

  2. Use an SSH client to log into your MPW Pro, user root, password is what you set above

  3. Run the following command to append a config line enabling SMB2:
    echo “max protocol = SMB2” >> /etc/samba/smb-global.conf

  4. Reboot and enjoy your MPW Pro connecting to Windows 10 machines without any special steps

I have tested this and it works on a 1TB MPW Pro SSD running firmware v1.04.17 and samba v3.6.25. These steps may not work on older firmwares if they are running versions of samba older than 3.6. Newer versions of samba have SMB2 enabled by default and do not need this special setting.

If any firmware updates break this, you may need to repeat these steps or otherwise find ways to modify the samba configuration. Honestly it would be great if WD firmware engineers can release an update with this enabled by default.


#28

In my case, I cannot see it under wifi in network share under windows 7.
Is there anything to activate ?


#29

Hey Vimp,

that’s exactly what I was looking for. Your hint works great. Had already my doubts, that I did a wrong choice with the WD Wireless Pro, but now I am fine. So, for all others out there, I can confirm, that changing the given line above in smb-global.conf leads to the fact, that you can use \192.168.60.1\Storage\ in the address line in Windows 10 again. And if you want you can map a network drive as usual (net use x: \192.168.60.1\Storage) …

Cheers


#30

Hi there,
I have tried this on my new MyPassport Wireless Pro 4TB, but is says:

login as: root
root@192.168.1.206’s password:
[root@MyPassport ~]# max protocol =>> /etc/samba/smb-global.conf SMB2echo
-sh: max: command not found
[root@MyPassport ~]# login as: root

I have the same firmware as yours is… any idea, pls?


#31

Do apologize, my mistake - using copy & paste is not always the best solution… :slight_smile:
I just have to restart later to see how it worked for me and will let you know - thanks anyways!


#32

Back again - so I have tried, the command seems to have executed, but even after restart is still offers opening an web page interface in Explorer. So it did not work for me…
There is another option, paying $35 for a custom firmware with more features here: https://www.hackwifidrive.com/wd-wireless-pro


#33

Also, I have just found out - Total Commander can see and access MyPassport/Storage just fine and is more feature-rich then the default Windows file manager, so I won’t bother… :slight_smile: