WD MyPassport 2TB not mounting - Windows 7 Home Premium with latest updates

I am having a similar problem to


I am on Windows 7 Home Premium, I gave up using WD software to backup my files as it was omitting files.  I have been using crashplan and/or manual copies.  All was going well until it stobbed being recognised and wouldn’t mount. It was final backups before I rebuilt my laptop (fortunatley I was using my NAS as well as I hate having my eggs in one basket !)

I rebuilt the laptop so everything was nice and clean,  The drivers seemed to install OK (the white light is flashing away).  but gain the drive won’t mount.

It shows up in the “saffely remove hardware!” tray icon.   I can see it in Device Manager with no apparent error messages

When I go into Computer Management however it brings up a dialogue saying “You must initialise a disk befpre Logical Disk manager can access it - select MBR / GPT”

Any ideas ?


If the drive is not seen when you connect it to your computer please try:

1- Disconnect the drive from the computer and restart the computer.

2- Please try connecting the drive to the back USB port of a desktop PC for testing purposes (directly to the PC, not through a USB hub).

3- Make sure you hear the connection sound windows makes when recognizes a USB device.

4- Go to "Disk Management” to verify if the drive shows up there. 

If the drive shows up in disk management but it is not seen on Computer, then it means the partition is corrupted and you will have to format it in order to use it again. Please note that formatting the drive will delete all data stored on it.

1 Like

Thanks for your help

Looks like it’s goosed.    It is seen in device & printers and in hardware devices.

When i go into disk mannagement I am asked to initialise it.     I have tried to do that but it doesn’t format complaining about an I/O issue,  Looks like I need to go via warranty :frowning:

This is my 2nd WD passport device which has packed up and I don’t think I am a heavy user as I tend not to carry it about.  Depending on one of these as the only place to keep data or even as a single backup source .would look like a very high risk strategy  

I have a WD My Passport Ultra 1TB which I have been using with a Mac.

Whenever I plug it into a windows computer it just tells me it needs drivers. I do all of that and install all of the software but to no avail.

Upon going into disk management I found that the disk shows up and is in a GPT Protective partition. The disk still worked on the mac but I cannot get it to work on windows. I no longer have access to the Mac as it has crashed and need to access my files on the hard drive. What, if anything can anyone reccomend I do to fix this problem. I have very important data on these drives and need it ASAP.

Any help is appreciated!

A disk formatted tor Mac will not work on Windows without additional software.