WD MyCloud via WD2Go won't let me open MS Office files - prompts for credentials

My new WD MyCloud drive works great locally. However remotely I’m having issues opening MS Office files.

I can perform standard file operations (copy/move/rename/delete) just fine via the wd2go interface, I can also open a plain text file and edit it just fine.

However if I attempt to open an Excel or Word document remotely it prompts for credentials and will not accept the login I registered for my User account on the drive.

I’m stumped - can anyone help?

I just went into wd2go and tried what you are talking about, opening a word document. I had to use my Network User Name and Password/Key for it to work. After that the document opened and then I had to click the Edit Document at the top of the page to make changes.

Update: I have been playing with this some more and after trying to open an Excel document and having to enter my credentials again I noticed a security icon showing in my taskbar and clicked on it. It ask me if I wanted to allow changes made to my computer and I clicked yes, After that I got out of wd2go, disconnected and then opened wd2go again. This time when I clicked to open the Excel document it opened and did not ask for credentials.

Edited again: I tried again and this time when I tried to open a word document I had problems so I just clicked on the x a couple of times, the box went away and my document opened up. See image below.


Posted by,
cat0w (USA)

I’m accessing remotely through wd2go - your screenshot shows you accessing a local IP. Not the same thing. The username/pw screen is not accepting my credentials and fails after about 3 attempts.

I heard WDCloud Desktop is a workaround instead of WD2GO and I installed that but it doesn’t open up an app or tool or anything so I’m still lost.

What does the image look like that’s asking for your username/pw? Does it look the same as what I posted?

How do you think I signed into wd2go.com? Using IE I had to enter my email address and password then all my shares showed and I opened one in explorer so I could open up word and excel documents. When I try to open a document that’s when I get the box asking for my credentials.

Posted by,
cat0w (USA)

After logging into the wd2go website I am able to see the shares and select “open in explorer” and I can see the files. However when I attempt to open an Excel or any other Office file I get the “Windows Security” popup similar to yours except in lieu of a local IP address like yours shows I have the wd2go.com device name “NAME-device#######.wd2go.com” and the Enter your credentials prompts for user/pw.

I’ve tried my cloud username, my email address and even the admin username and password. None of the credentials are accepted. Is there a workaround as the “explorer” method is way better than the MyCloud Desktop version. Also, you can create a mapped drive using the wd2go address which is way more useful as well.

I’d really like to be able to open my MS Office docs this way.

The only other user name and password to try would be your networks. For me that is the user name and password I created when I set up my router.

Posted by,
cat0w (USA)