WD MyCloud suddenly stopped showing up under "MY Pc" on Windows 10. Still see it, but can't change anything


#1

My WD MyCloud has been working like a dream for a couple of years. All of a sudden, it has stopped appearing as an editable hard drive under “My PC” on Windows 10, however it still shows up as an uneditable “WDMyCloud” - I can view, watch anything that’s on it, but it no longer shows up as a “Z” drive where I can add & edit things… I’ve googled everything possible and spent several hours on this…

HELP…


#2

@Dave16 Do you own a My Cloud or My Cloud Home? If a My Cloud is what you own, what, if any, troubleshooting steps have you tried other than googling for an answer to your problem?

Have you rebooted your My Cloud? Have you rebooted your Computer? Have you unmapped the drive and then mapped it again?


#3

Thanks - have tried all of those - the MyCloud (not home) has been rebooted several times, as has the computer. I’ve tried to unmap & remap, but as it doesn’t show up in the list it won’t let me do either… it just doesn’t recognise it as a hard drive anymore…


#4

@Dave16 I don’t know if this will help or not but you may want to look at it.


#5

Thankyou, really appreciate the response. Sadly, it was all already ticked… :frowning: