WD Mycloud suddenly excrutiatingly SLOW

Guys, please help!

I have a 2TB WD Mycloud home (the white box). It worked fine for about 6 months but all of a sudden it’s acting up in a very strange way.

Files that are currently on the drive are accessible via FTP and when copying from the drive to my PC I get expected speeds of transfer.

BUT when I try to copy anything onto the Mycloud all fails. I tried copying txt files as small as 20kb and would be getting 4 kilobytes per second speeds. Trying anything above 1 MB and it simply crashes my File Explorer.

Info about my setup:

Windows 10
Gigabit switch
Gigabit router
WD connected via CAT 5 cable (tested multiple cables, different slots)
SMB3 (SMB2 or 1 don’t work for me, can’t access files with those)
Tried to reset to default settings
Turned off itunes / DLNA in the web interface
Tried multiple reboots
Tried turning off Windows defender firewall and antivirus
Tried scanning the drive (no errors)

Basically, I’m out of ideas. I’m pretty handy with these things but this thing is driving me nuts. This all started acting up about a week ago. Up until now it was fine.

Most confusing part is that the download speeds are normal, about 100 MB/s, but copying onto the Mycloud just doesn’t work.

I would really appreciate any advice because after spending 10 hours on troubleshooting this myself, I just don’t know what else to try.

1 Like

Which device do you have? The My Cloud and My Cloud Home are different devices with different features/options. This is a My Cloud device:

This is the My Cloud Home:

If you have the My Cloud Home, see the dedicated subforum for that device where people more familiar with that device may be able to assist. This subforum (My Cloud) generally covers the single bay My Cloud device which is not the same as a My Cloud Home device.

https://community.wd.com/c/home-cloud-storage/my-cloud-home

Edit to add: Couple of general suggestions. Because you are using Windows 10, ensure SMB 1.0 is enabled. Microsoft disabled this option with recent patch updates to Windows 10.

https://support.wdc.com/knowledgebase/answer.aspx?ID=20736

Try using another computer or mobile device to see if the copy speed using a File Manager is the same or different. That will help isolate the issue to either the WD product or the one specific Windows 10 PC.

It’s the first one, WD MyCloud. I tried through my phone and had same issue - very slow write speed but no problems with reading files.

Access the My Cloud Dashboard (using a web browser) and check the free space. If there is little free space left on the drive that might contribute to sluggish/slow behavior. Also in the Dashboard check the Diagnosis option to see if there are any issues/problems with the hard drive.

I forgot to mention it, but that was among the first things I did… More than a 1TB of free space and Diagnostics report that everything is peachy. I even did the system check and disk scans and everything came back normal.

I am now beginning to think that maybe one of the file transfers broke mid-way and that a single file is causing this whole problem. Because I tried deleting the last directory I created and it wouldn’t let me, I just get an error message. Problem is that this MyCloud doesn’t have file browser in the web interface so I can’t get to the directory any other way than through the Windows Explorer. I tried through my phone and a laptop but no luck.

If you are connected to the same local network as the My Cloud you can gain access to the My Cloud at the root level using SSH. From there you can force delete a file or folder. One enables SSH through the My Cloud Dashboard > Settings page. Taking care to delete the right file/directory since one could brick their My Cloud if they delete something needed by the firmware. One can use Putty (https://www.chiark.greenend.org.uk/~sgtatham/putty/latest.html) terminal command line program or use a GUI interface like that provided by WinSCP (https://winscp.net/eng/index.php)