WD MyCloud stuck at safe mode

. . . if you are heading down that route of data recovery. . .

. . .try extracting the hdd; place it in an external enclosure, and try to read the data with a PC.

Note that the HDD will be formatted with EXT4; so won’t be directly readable by a WinPC. You will need a driver (program) that can read EXT4 using LINUX in a Windows environment.

Just to make sure, you followed the following procedure for performing a 40 second reset?

To execute the 40 Second Reset :

  1. Power down the device and remove the power cord from the device
  2. Using a paperclip or narrow tipped pen, press and hold the reset button
  3. While continuing to hold the reset button, reconnect the power cord to the device and continue to hold the reset button for at least 40 seconds
  4. After releasing the reset button the device will reboot

Note: This process may take upwards of 15 minutes. Please wait until the Power LED is solid blue, indicating the device is ready to use.

Edit to add: Couple of other suggestions. Temporarily disable any web browser add-ons/extensions. Its possible one of them may interfere with the safe mode page loading or uploading of a file. Same goes for any third party security software on the computer. Disable the security software and see if the issue persists.

If the firmware is corrupted to the point it cannot be fixed via normal methods then one may have to resort to using one of the unbrick processes. Down side with unbricking is one may have to erase the hard drive by re partitioning it. User Fox_Exe has directions (see the repository here: https://fox-exe.ru/WDMyCloud/ some here have used successfully to recover their single bay My Cloud hard drive. Its possible one might be able to jury rig those directions to just push the firmware image files to their appropriate locations (except the EXT4 user data partition). Like indicated above, if using windows, to recover or back one’s data from a corrupted My Cloud hard drive one will need third party Linux drivers or use a Linux boot disc/USB flash drive.

One other possibility. If one previously had SSH enabled and can still access their single bay My Cloud using SSH. Then it might be possible to push the firmware to the My Cloud using SSH. No idea if this works. No idea if it works on the second gen single bay My Cloud units. The two discussions below may only be dealing with first gen single bay My Cloud units. As always proceed at your own risk. Backup your data first (if you can). One will have change the URL’s for the firmware to download the latest one’s. See the My Cloud Support website for links to the latest firmware.

Hi @Bennor @NAS_user @cat0w,

thanks for all the solutions advised.

thanks God, I finally manage to upload the firmware after reset.
all of the data is still in the drive, I manage to back up all important data from My Cloud to another external hard disk.

then I run 3 different test available in the setting, System test (passed), Scan disk (passed) but both Disk test (quick test & full test) are failed, showing Drive SMART failure, code 3.

I try to replug all the cable and reboot the WD my cloud, finally manage to run and passed the Disk test (full test) after 8 hours. I will try to run both Quick test and Full test once more to be assure it’s okay.

anyway, should I be concern of the error or send to fix?

after the passed on full disk test, I run the first quick test unfortunately it failed again then i reboot the WD my cloud and passed on the second quick test.

then I run another full test which failed again.

I’m not sure what is wrong here.

A SMART drive warning typically (in most cases) indicates the drive is likely on it’s way to failure or there is serious issue with the drive. One should backup their My Cloud data immediately.

One can try to read the SMART info by using the following command (issued via SSH to the My Cloud).

smartctl -H /dev/sda

That command might give one a clue to what the SMART warning is.

If one wants to replace the hard drive inside their single bay My Cloud, there are a number of “unbrick” methods (or drive cloning options) that one can use. One can use the forum search feature for many past discussions on replacing the single bay My Cloud hard drive.

Edit to add: If one has a multi bay My Cloud model then see the specific subforum for that device to see how to replace one or more drives in that device.


I had backed up all of my data.

is there any way I can diagnosis or understand what’s wrong with the WD My Cloud before replace the hard drive inside.

My prior post explains one way to try and get additional information on what might be wrong with the drive.

One can try to read the SMART info by using the following command (issued via SSH to the My Cloud).

smartctl -H /dev/sda

That command might give one a clue to what the SMART warning is.

One would have to enable SSH through the My Cloud Dashboard > Settings section then use an SSH client (like Putty if using Windows) to issue commands to the My Cloud using SSH.

Another option is to remove the hard drive from the My Cloud enclosure and attach it to a computer (using a USB to SATA adapter, a spare SATA port, a SATA docking station, etc.). Then using Linux (or a Linux boot disc/USB flash drive) one can try and run Linux drive health programs against the drive to see if it can determine exactly what is wrong with the drive. Because of the custom nature of the My Cloud firmware one typically cannot download and run Linux programs within the firmware itself even though the firmware uses Linux. Doing an apt-get or installing programs to the My Cloud OS may render the firmware corrupt. One can find a number of online articles about how to check a drive using Linux.

Ubuntu is one popular Linux disto that can be run as a boot disc or boot USB flash drive.


appreciate your help.


there is nothing I can do or repair on the hard drive?
I think it’s not worth to buy a new WD red hard drive to replace it compare to get a new WD My Cloud.


thanks you all for the solution advised, luckily I manage to back up all my important data before it fails completely.

While one can attempt to fix certain SMART errors like heat warnings, once a drive shows errors like reallocated sectors that means the drive is on its way to failing. There are some software programs that will attempt to fix sector reallocations and other errors it is usually a stop gap temporary measure as the drive will continue to fail.

Note that the single bay My Cloud unit are typically no longer being sold as brand new devices rather they are either used or refurbished. WD is phasing out support for the second gen and the first gen is already no longer being supported. And the My Cloud Home, as many have unfortunately discovered, is not like the My Cloud, and is not a direct replacement for a single bay My Cloud unit.

One can replace the single bay/single drive My Cloud hard drive with another hard drive. In the United States the 4TB WD Red drive(s) typically can be found on sale from time to time for $100 or less at Amazon, New Egg or Best Buy. But in reality one could almost use any non SSD hard drive in the unit if they had a spare one laying around. Plenty of past discussions on replacing the My Cloud hard drive with a larger (or smaller) hard drive that can be found using the forum search feature (magnifying glass icon upper right). Search for “unbrick” or “unbricking”. What quite a few do is buy WD Easystore Desktop drives that go on sale from time to time and “shuck” the hard drive from it’s enclosure and use the bare drive in NAS enclosures from various manufacturers.

What ever one decides, it is always advisable to use the backup method included with the NAS operating system to guard against drive failure. On the My Cloud the backup feature is called Safepoint on the first gen or Backup on the second gen in the my Cloud Dashboard. Then its a simple method of restoring that backed up data to a new drive (or access that data on another computer when the NAS fails).


thanks for your detail explanation.

do you know any software can fix the reallocated sectors and the steps to share?

I have read some discussion post and WD article, I do notice there is some hardware different between WD MyCloud and WD myCloud Home. I do saw some people mention it’s no longer consider as NAS, but I don’t understand the software or usage different.

4TB WD Red is sold at around $100 at my country as well, I might wait for sales then.
any chances that my besides the hard drive any problem with my WD mycloud? as I worry the problem not only on the hard drive but on other parts too. if that case, replacing hard drive will not fix the problem.

One isn’t “fixing” a bad sector on a hard drive. What one is doing (in simplistic terms) is marking the sector as bad and using a backup/reallocated sector in its place. The issue comes there is a finite number of backup/reallocated sectors and once those are used up replacing bad sectors, the data gets corrupted, SMART throws errors and the drive has problems as additional bad sectors arrise. Like indicated previously trying to reassign bad sectors is a temporary fix at best, the drive is still failing. One can use their favorite internet search engine to search for repairing bad hard drive sectors or removing bad sectors. There are some basic free tools (Windows chkdsk for example) out there along with paid software like HDD Regenerator. Personally while I have recover the use of the drive for a short time, it always fails eventually. Sometimes within hours of running recovery tools, sometimes days or weeks later. But in the end the drive always ends up being replaced.

The My Cloud Home uses a different operating system than the My Cloud line. It has different features and different options. For example no Dashboard and no SSH capability. It’s operating system is, as I understand it, Android. Configuration of the unit is done using (again as I understand it) a mobile app.

If you are worried about the issue being with the My Cloud backplane hardware and not the drive itself one can always take a spare unused bare hard drive and unbrick it to work in the My Cloud. I’ve run drives as small as 250GB in a first gen single bay My Cloud enclosure some may have even run smaller drives. Currently using an old laptop’s 2.5 inch 750GB drive in the single bay My Cloud as its a secondary hardly used NAS device now that I use a larger, more capable, unit from another manufacturer.

It comes down to the issue of time and effort. Sure one can spend hours/days trying to repair a failing hard drive, but in the end you still have a failing drive that could fail completely at any time. Or one can spend some money to simply replace the failing drive by spending a little bit of time (half an hour to an hour) on top of the new drive cost unbricking a brand new (or existing used) hard drive for use in the single bay My Cloud.

I agree. . . there is no profit in salvaging a half failed drive. . .sure; you may get a few months use out of it before it fails completely. THEN WHAT?

So then there is the question of tossing a nice new NAS HDD in the existing unit. . . .or doing the American thing and starting over with a fresh unit.

Back in the day. . . the WD MyClouds represented an awesome value for the dollar. I really like my Gen 1 unit; and currently use it sporadically as a standard network drive.

However. . .today. . . one must face the fact that “the handwritting is on the wall” regarding all the OS/3 units (like the Single Bay MyClouds) in terms of firmware support and access using WD Web/phone apps. Firmware support in general is very important if these units are exposed to the internet.

The OS/3 cloud apps. . .I think are on a clock before the WD servers are switched off. WD seems all in on the new OS/5 ecosystem. From what I infer on the OS/5 forums; I suspect the Single Bay myclouds simply don’t have the horsepower to run OS/5.

Unfortunately, you simply can’t get new NAS units at the old Single Bay WD price points. On the plus side; the new units are definitely snappier and more capable in my view to run software like Plex.

So if I was in your shoes. . .
. . . I would consider “playing” with the unit and slapping in a new HDD. (make sure it’s a CMR drive, not a SMR drive)
. . I would SHUN anything from the MyCloud Home line.
. . .I would consider buying a new synology or qnap unit for any “mission critical” work. (All the WD NAS units going forward will be OS/5 - - -and that software is far from “proven” for “mission critical” applications)

Hi everyone,

I have a WD My Cloud device, 6Tb, gen 2, and I haven’t found any info about unbrick this unit in particular.

I followed the procedure described at the topic “Success recover my MyCloud 3TB with fast blue blinking light after update firmware!”, but like lot’s of people, I’ve got stuck at safe mode with “Firmware Version: (BLANK)”.

When I tryed to Update the firmware at this point, the progress bar started to move, but no percentage was showing. There was no progress at all.

Before start to try something less conventional, I decided to save my files following the steps at this toppic “My Cloud dead, how to see content on Windows 10?”.

I use the Ubuntu aproach. Downloaded Ubuntu and ran it from a pendrive. The process to create the pendrive is here “Create a bootable USB stick on Windows | Ubuntu”.

After save my files, I tryed to move on, without formating my HDD.


I use the command “mkfs.ext4 /dev/sda3” at telnet to format all the little partitions at the HDD. I just left the big one with all my files. You need to change the “…sda” part to the number of partition, in my case
“mkfs.ext4 /dev/sda3”, than 4, 5, 6 and 7. The partition 1 was the system partition, the 2 where my files.

PS.: You can skip this part! Just for curiosity, when started to format these partition as I sad, I notice that I had a “boot” folder at partition sda3 and sda5. The one at sda3 I must have created while following the procedure at the first topic above… the one was the original. And there were 2 files, named “rescue_fw_version”, I thought it has to be with the "Firmware Version: (BLANK), tryed to copy them to sdb3 partition and erase “boot” folder at sdb5 partition, but it didn’t work.

After formating the partitions, I started to follow the topic “Success recover my MyCloud 3TB with fast blue blinking light after update firmware!” again and voila! Problem Solved!

Another thing, while choosing the firmware file from WD site, I’ve got some errors. The firmware that worked was the .BIN file. .TAR.GZ, .TAR files, didn’t worked out for me.

The system was restored, but it didn’t manage to recover my files. It didn’t show the files I left there. I needed to choose a RAID mode while configuring it and it got formated. So, before move one, you need to save all your files as described at the topic above!

Thats it! Hope to help! I haven’t find any solution at the forum about these "Firmware Version: (BLANK).


Hi, how did you manage to fix this issue? I’m having the same issue on my WD My Cloud 4TB model. Tried both 4sec and 40 sec reset. Looks like the firmware corrupted when I tried updating it via the dashboard to 5.15.106 and trying to do this via safe mode is also not working. TIA

Same here. Device broken after „upgrade” to OS5 from the last Fw2.
No support from WDC

HI Jacksiow, I’m stuck in the same problem too. The uploading firmware status is just rotating forever. which managed to help you get thru with it? Hope you can share it with us pls.


Hey there,

I have done the 40 sec. reset properly, but the device doesn’t do anything and it’s still blinking red after 30+ Minutes. I’ve tried the 40 sec. reset many times and in fact even after 60 sec. I can reach the safe mode page and choose a file, in my case My_Cloud_GLCR_2.42.115.bin, and start with the upload.

Unfortunately, the upload never ends. Can you please explain what did you do manage to upload the firmware?