WD MyCloud Slow Read Speeds (10Mbps) when Connected via ActionTech router: Solution

While configuring a WD MyCloud  I noticed incredibly slow read speeds in the range of (7-9Mbps – i.e. a 10Mbps connection.)

Write speeds were in the range of 60 -70 Mbps (expected / acceptable for a 100 Mbps NIC)

(Yes I know best to upgrade to a gigabit NIC… but that’s not the point.)

I experienced this problem only when the PC and MyCloud (NAS) were connected via an ActionTech router (MI424WR-GEN3I) from Verizon. When I connected the PC to the MyCloud via (gigabit capable) switch (so the switch connects the PC and NAS before hitting the router) I got read speeds slightly higher than the write speeds  – as expected.


   router : switch : PC : NAS  – OK

   PC : router :  switch : NAS or  PC : router : NAS – both yielded 10Mbps reads

This narrowed the problem down to the router.  Seems that having a port configuration of 1000 Mbps and 100 Mbps (regardless if explicitly set or auto-detected) throttles the reads back to the 10 Mbps range instead of 100 Mbps – bad speed negotiation.

The fix/workaround was to go into the port configuration and “downgrade” the speed of port the My Cloud was on to 100 Mbps.  Note: It did not matter if there was a gigabit switch on the down side of the router (between the router and NAS)

(On the ActionTech router settings:  Advanced > Port Configuration > Change port speed from Auto / 1000 to 100)

I hope this helps some folks experiencing similar problems.

(I had searched other posts and the Net for a solution but came up empty.  WD tech support didn’t offer much help other than to point to the posts and failing requesting a RMA.)

Used the free LAN Speed Test Lite to test the network read and write speeds.


Welcome to the Community and thank you very much for sharing your experience. This is helpful information.

1 Like