WD MYCLOUD NAS - Computer does not recognize

I’m new here so bear with me. My ASUS computer crashed. Brought it in and they installed a new hard drive and uploaded Windows 10. They also recovered some files from the old and installed as well. Also bought another ASUS with Windows 11 installed. Brought both home and set up the newest ASUS with Windows 11 and linked it to my NAS without any problem. Just went to File Explorer and it came up right away under Network.

Next I went to my old ASUS with the new hard drive and Windows 10. File explorer does not see the NAS listed under Networks and I can’t link it. I can’t seem to connect it any which way I have tried.

I tried a direct link with an Ethernet cable but when I turned it on and the NAS booted up I got a solid Red light (Bad News) on the front. I reconnected it through the WIFI and when it booted it was solid Blue (Good News) and the dashboard said it was all good.

What am I doing wrong and what is the right way of doing it.

Thanks for any help on this.

Hi @Yakherder,

Have you opened a Support Case? If not opened, for more information, please contact the WD Technical Support team for the best assistance and troubleshooting:
https://support-en.wd.com/app/ask