WD MyCloud Mirror - USB Platte wird nicht mehr angezeigt

Hallo,

nachdem ich eine Spannungsunterbrechung an meiner Externen Festplatte (WD My Book), die über USB 3.0 an meinem WD My Cloud Mirror angeschlossen ist, kann ich nicht mehr auf diese Fetplatte zugreifen.

Ich hatte seither die externe Platte mehrfach vorschriftsmäßig abgemeldet, abgezogen und wieder angeschlossen. Auch hatte ich das MyCloud mehrfach neu gestartet (im Dashboard - Einstellungen - Hilfsprogramm - neu starten). Bei den USB-Geräten im Dashboard wird die externe Platte sogar erkannt und mit Seriennummer, Größe, usw. angezeigt, bei den Freigaben erscheint sie aber nicht. WD-Discovery erkennt sie ebenfalls nicht, und als Netzlaufwerk lässt sie sich in Windows Vista auch nicht mehr verbinden.

Wenn ich versuche ein Backup vom NAS auf die USB-Platte zu ziehen, erhalte ich eine Fehlermeldung. “Fehler bei der Sicherung”. Wenn ich dann versuche, den alten Auftrag, der bis gestern noch funktioniert hat, zu bearbeiten, finde ich beim Durchsuchen des Ziels zwar den Namen der USB-Festplatte und die vorhandene Ordnerstruktur. Wenn ich den Haken vor den Namen der Platte setze und bestätige, bleibt das Feld Ziel aber leer.

Wenn ich die USB-Platte wieder vom WD MyCloud trenne und am PC anschließe, kann ich ganz normal auf sie zugreifen. Das Problem scheint also am MyCloud zu liegen?

Langsam weiß ich nicht mehr, was ich noch probieren soll, um die externe Platte wieder für Backups des MyCloud Mirror heranziehen zu können.

Wer kann  mir helfen?

Herzliche Grüße,

Wein-Franke

Nehme doch bitte mal diesbezüglich Kontakt mit dem Technischen-Support von Western Digital auf. Hier die Nummer :

00800- 27549338

Mo-Do : 9:00 – 19:00 MEZ
Fr : 9:00 – 17:00 MEZ

Den Anruf habe ich zwischenzeitlich getätigt. Nachdem ich erwähnt hatte, dass eine andere externe Platte (eines anderen Herstellers), in den Freigaben des MyCloud Mirror angezeigt wird, wenn sie am MyCloud angeschlossen ist, tippte der Mitarbeiter auf einen Fehler beim MyBook. Richtig überzeugt klang er dabei aber selbst nicht. Jetzt läuft die nächsten Stunden über der “extended” Festplattentest (WD Data Lifeguard Diagnostics). Wenn dabei nichts rauskommt, hatte er noch als Option, die externe Platte neu zu formatieren.

Ist zwar “nur” ´ne Backup-Platte - aber wer löscht schon gerne seine Backups - was tun, wenn genau dann auch die Originaldaten verloren gehen? Ich erinnere nur an Murpheys Law…

Hi,

ich kenne das Problem. Ist mir schon öfters passiert. Und ich muß sagen, mir geht’s ähnlich wie Dir. Ich mag auch keine Backups löschen…

Das Problem läßt sich reproduzieren. Wie Du schon ganz richtig geschrieben hast tauchte Dein Problem NACH einem Stromausfall auf.

Das ist nix Neues. … Immer dann, wenn die USB-HDD ohne Abmeldung ausgestellt wird und/oder der USB Stecker einfach ohne Abmeldung gezogen wird, erkennt das MyCloud System die vorhandenen SAFEPOINTS nicht mehr. Zumindest ist es so bei meiner einfachen MyCloud. Das es bei der MC-Mirror auch so ist war mir bisher nicht bekannt.

Nun denn…und es kann nicht am Gerät legen - weil ich inzwischen das Dritte Geräte im Austausch habe. Hier handelt es sich ganz klar um einen Systemfehler (wobei iss eben Linux - da kann man nicht einfach "Stecker ziehen).

Du bekommst das externe USB-HDD nur wieder zum Laufen

  1. Wenn Du noch Platz genug hast und ein neues Backup /Safepoint erstellst

  2. die Platte neu formatierst

Ich wünschte auch es geht anders. Hab’ gerade mal wieder … formatiert

Gruß

Lucky

Hallo real_Lucky!

Das sind aber keine guten Nachrichten. Muss ich jetzt auch noch Geld für eine unterbrechungsfreie Stromversorgung ausgeben?..

Ich kenn mich mit alternativen Betriebssystemen nicht aus. Aber in anderen Foren las ich immer, dass LINUX in vielerlei Hinsicht genialer sei, als Windows. Hier stimmt das wohl nicht.

Nur des Verständnisses wegen, was beim MC Mirror als Sicherungen bezeichnet wird, heißt beim “einfachen” MyCloud “Safepoint”. Wobei das MyCloud Mirror hier die verschiedenen Quell- bzw. Zielmedien mit je einem eigenen Menüpunkt beglückt. Und eben gerade bei Sicherungen auf externe USB-Platten hat man da keine regelmäßigen Backups nach Kalender vorgesehen, sondern bietet dafür die Option “automatisch starten, wenn verbunden” an. Was ja fast suggeriert, dass man die externe Platte nach Belieben anschließen und trennen könne.

Zu deinem Lösungsvorschlag:

Waren die zwei Punkte als Alternativen gedacht? Oder bedeutet das 1. wo anders sichern und dann 2. formatieren? Denn wie gesagt, wenn ich die externe Platte über das MCM im LAN-Netz ansprechen will, wird die Platte überhaupt nicht gefunden, obwohl sie im Dashboard unter den USB-Datenträgern sogar mit Hersteller, Modell und Seriennummer angezeigt wird. Es fehlt also nicht nur der Zugriff auf den Ordner, auf den vorher die Backups des MCM abgelegt wurden.

Außerdem, reicht eine Schnellformatierung der Platte unter Windows Vista aus?

Langsam aber sicher lässt die Begeisterung über mein geniales Sicherungssystem nach…

Hallo real_Lucky!

Der Festplattentest ist jetzt durch. Die Platte ist demnach einwandfrei. Hätte mich auch gewundert, wenn es anders gewesen wäre. Als “normale” USB-Platte am Vista-PC läuft sie ja auch sauber.

Nun würde mich doch interessieren, wo die entsprechenden Daten für die Verbindung zwischen dem LINUX-System des MyCloud Mirror und einer bereits früher einmal angemeldeten USB-Platte gespeichert werden. Auf der externen Platte oder im My-Cloud? Deine Beobachtung, dass mit Formatieren der externen Platte quasi ein Reset möglich sei, deutet auf die Speicherung auf der externen Platte hin.

Wenn man also nur die entsprechende Datei auf dieser Platte resetten könnte, ohne die Platte selbst neu zu formatieren, könnte man die Backupjobs vermutlich neu anlegen, ohne vorhandene Inhalte der Platte zu zerstören. Abgesehen davon, an der USB 3.0 Schnittstelle brauchte mein Rechner 5 Stunden für den “Extended” Test. Ein Hin- und Herkopieren auf eine andere Platte dauert dann sicherlich noch länger.

Mal sehen, ob mir die Hotline hier doch noch weiterhelfen kann.

Ein System, das so leicht abstürzt, ist den Vertrauensvorschus nicht wert, den man einem System eines namhaften Herstellers gerade in diesem sicherheitsrelevanten Bereich gewährt. Schließlich habe ich das Teil ja nicht im Discounter zwischen den Windeln und dem Gemüse gefunden!

Schönen Abend noch,

Wein-Franke

@real-Lucky:

Diese Woche hat mir der Support nach über 2 Wochen Bedenkzeit bestätigt, dass es das einfachste sei, die externe Platte komplett mit Nullen zu beschreiben. WD hat sogar ein extra Tool dafür.

Das ist für mich keine Lösung. Meinetwegen irgend eine Systemdatei löschen, und damit auch die Backupeinstellungen, die ich nach der Neuanmeldung der Platte wieder neu anlegen kann. Damit könnte ich leben, aber keine Daten. Das hieße ja, ich bräuchte noch eine Backuppllatte. Und dann der Zeitaufwand. Wenn dann morgen wieder mal die Sicherung fliegt, geht das Ganze von vorne los?

Nee, da gebe ich das System lieber zurück, und kauf mir eines von einem anderen Hersteller…

Super, hier der gleiche Mist.

Ich habe eine brandneue HGST Touro 1GB als USB Backup welche bis eben einwandfrei lief und auch bei den Freigaben erkannt wurde. Dann wollte ich einem Nutzer Schreib/Leserechte auf dem USB Gerät einräumen und dabei hing sich irgendwas auf. Im Browser tat sich nicht mehr als das Overlay mit “Bitte warten…” Also irgendwann mal den Brwoser aktualisiert, doch die Schreibrechte hatten sich nicht geändert und zu allem überfluss ließ sich auch die Platte nicht mehr vom der MCM abmelden. Ein Neustart der MCM half natürlich auch nichts und so bleibt einem irgendwann nichts mehr übrig als den Stecker zu ziehen.

Von da an hab ich genau das was Wein-Franke schon beschrieben hat, oben bei den USB-Geräten wird die Platte noch erkannt, bei den Freigaben wird sie aber nicht mehr angezeigt. Glücklicherweise hab ich noch eine zweite USB Platte deren Backup noch funtioniert und wenn ich die HGST jetzt nur durch formatieren wieder an die MCM zu bringen ist, ist das mal richtig ■■■■■■e. Da täte ein Update aber wirlich Not.

Gruß

Ronny

Weiter gehts:

Auf der externen Platte findet man eine Datei Namens .smbn. Löscht man diese wird die Platte zumindest mal wieder von der MCM erkannt und in den Freigaben aufgeführt. Damit sind dann aber auch alle Infos für die MCM weg wie die Platte behandelt werden soll. Also ob öffentlich oder nicht bez. wer welche Rechte hat. Denn die Infos werden wohl dort gespeichert. Das größte Problem an der Geschicht ist aber das damit der Backupjob am ■■■■■ zu sein scheint. Versucht man das Backup laufen zu lassen erstellt die MCM exakt den gleichen Backup Ordner wie in dem Auftrag angegeben nochmal und erkennt nicht das bereits alle Daten vorhanden sind bez. das nur syncronisiert werden soll. Was bleibt ist die Platte unter Windows zu (schnell) formatieren und alles auf Anfang zu setzen um dann wieder ein komplettes Backup laufen zu lassen. Wieso gibt es eigentlich im Dashbord keine Möglichkeit externe Platten zu formatieren? 

Und ganz ehrlich, Backups sind das A und O, das sowas dann nicht gescheit und zuverlässig läuft ist eigentlich kaum hinnehmbar und wie ich oben schon schrieb sollte da was seitens WD passieren damit das besser klappt. Im Moment kann man jedem Nutzer nur empfehlen zwei Backups auf 2 verschieden externen Platten vorzuhalten weil man nie weiß wann die MCM beim anstöpseln der USB Geräte rumzickt. 

Gruß

Ronny

USB Platte formatieren sollte das Problem beheben. Bitte die Platten immer im Dashboard auswerfen.

Bart_S wrote:

USB Platte formatieren sollte das Problem beheben. Bitte die Platten immer im Dashboard auswerfen.

Genau das ist ja das Problem, wer formatiert schon gern eine in Gebrauch befindliche Festplatte? Wenn es auch “nur” eine Backupplatte ist. Jeder kennt Murphy´s Law. Dazu dauert es am PC Stunden, die Daten, falls überhaupt noch ein Datenträger vorhanden ist, zu kopieren.

Platten über Dashboard auswerfen -  schön und gut, aber was mache ich bei einem Stromausfall, einem wackeligen Stecker, oder wie in diesem Fall, wenn sich das Gerät aufhängt?

Ich bleibe dabei, es ist eine bessere Lösung für den Fehler dringendst erforderlich. Bevor diese Firmwareupdate erscheint lautet mein Rat: Finger weg von dem Gerät! Schade eigentlich, denn ansonsten ist es ganz passabel.

MfG

WeinFranke

Hi,

@Wein-Franke schreibt:

" … Rat: Finger weg von dem Gerät! …"

Ich persönlich finde das ein wenig drastisch. Immerhin versieht das Gerät, bis auf Teile der Backupfunktion seinen Dienst. Ein problemloses Backup über das Netzwerk ist ja dennoch möglich.

Inzwischen scheint die Widererkennung eines Safepoint auf der USB-HDD, nach dem Stecker ziehen oder Stromverlust, zu funktionieren. Zumindes bei meiner einfachen MyCloud…  Es gibt zwar immer noch eine Fehlermeldung, jedoch die mit “Ignore” abbrechen und dann ging’s.

Gruß

Lucky

1 Like

Ganz so drastisch würde ich das auch nicht sehen, aber es wäre schon gut wenn sich da was ändert. Grundsätzlich ist die MCM genau das was ich mir vorgestellt habe und brauche. Man muss nur wissen das man im Prinzip zwei Backups benötigt um einfach mehr Sicherheit zu haben.

Weiter gehts:

Eben mal wieder ein Backup versucht und dabei hat sich dann wieder was weggehangen so das ich die externe Platte nicht korrekt auswerfen konnte. Also abgogen und nebenbei festgestellt das ein längeres Kabel nicht mit der externen Platte harmoniert. Besser das originale Kabel verwenden, das aber nur nebenbei.

Wie immer wurde die USB-Platte später nicht mehr erkannt. Ich hatte ja schon mal geschrieben das auf der Platte eine Datei namens “.smbn”. Darin enthalten sind Infos für die My Cloud Mirror wie die Platte zu handhaben ist. 

Der Punkt ist jetzt, wird die Platte nicht richtig abgemeldet ist diese Datei korrupt. Ersetzt man jetzt die defekte Datei durch ein Backup der Datei ist der Spuk vorbei und alles läuft als wäre nichts gewesen. Die Platte wird korrekt erkant und der Backup Auftrag wird auch richitg ausgeführt.

Für mich ist das eine einfache und praktikable Lösung. 

Nachtrag: Falls jemand wie ich auf die Idee kommen sollte die Backup smbm Dateien umzubenennen: Das geht nicht unter Windows. Falls man es wie ich jedoch schon versucht hat, das Android Handy macht aus einer xy.smbm.xml Datei wieder eine .smbm.xml Datei. :wink:

rl2664 wrote:> …Ich hatte ja schon mal geschrieben das auf der Platte eine Datei namens “.smbn”. Darin enthalten sind Infos für die My Cloud Mirror wie die Platte zu handhaben ist. 

Der Punkt ist jetzt, wird die Platte nicht richtig abgemeldet ist diese Datei korrupt. Ersetzt man jetzt die defekte Datei durch ein Backup der Datei ist der Spuk vorbei und alles läuft als wäre nichts gewesen. Die Platte wird korrekt erkant und der Backup Auftrag wird auch richitg ausgeführt.

Für mich ist das eine einfache und praktikable Lösung. 


Verstehe ich richtig, eine Kopie anlegen und nach dem nächsten Absturz das Original durch diese Kopie ersetzen? Was passiert, wenn die Kopie schon älter ist?

Ich werd es mir ansehen, wenn ich wieder einmal Zeit dazu habe. Wenn es wirklich so einfach ist, warum macht dann der Support den Vorschlag nicht? Ich hatte ja auch konkret nach einen Workaround ohne Formatieren gefragt.

Viel steht ja in der Datei nicht drin. Und versteckt ist sie auch nicht. Wie aber erzeuge ich den Dateinamen mit dem Punkt am Anfang unter Windows? Mir stehen derzeit Windows Vista und 7, sowie 8 auf dem Rechner meiner Frau zur Verfügung.

Grüße,

Wein-Franke

Wein-Franke wrote:


 

Viel steht ja in der Datei nicht drin. Und versteckt ist sie auch nicht. Wie aber erzeuge ich den Dateinamen mit dem Punkt am Anfang unter Windows? Mir stehen derzeit Windows Vista und 7, sowie 8 auf dem Rechner meiner Frau zur Verfügung.

 

Grüße,

 

Wein-Franke

Gar nicht. Normal ist das auch nicht nötig, denn wenn man die Datei kopiert akzeptiert Windows sie so wie sie ist. Umbenennen geht auch, aber zurück kommt man nicht mehr weil windows meckert das vor dem Punkt nichts steht. Ich wollte die auch nur umbenennen weil ich zwei USB Platten habe und nicht zwei Dateien mit gleichem Dateinamen an einem Ort speichern kann. Man muss die Datein halt in zwei verschiednen Ordnern sichern, in meinem Fall halt einmal für die Touro und einmal für die Elements.

Das Alter der Datei scheint keine Rolle zu spielen. Und ja, es ist so einfach. Festplatte an den Desktop/Notbook/whatever, Datei austauschen, läuft wieder.

Ich finde auch ein bißchen traurig das man sich sowas selbst erarbeiten muss, zumal die Belastung auf der MCN nicht unerheblich ist wenn man formatiert und alle Daten nochmal verschieben muss. Wenn dieser Weg dauerhaft funktionert ist das eine deutlich einfachere und vor allem schnellere Variante.

1 Like

rl2664 wrote:


 

Das Alter der Datei scheint keine Rolle zu spielen. Und ja, es ist so einfach. Festplatte an den Desktop/Notbook/whatever, Datei austauschen, läuft wieder.

Ich finde auch ein bißchen traurig das man sich sowas selbst erarbeiten muss, zumal die Belastung auf der MCN nicht unerheblich ist wenn man formatiert und alle Daten nochmal verschieben muss. Wenn dieser Weg dauerhaft funktionert ist das eine deutlich einfachere und vor allem schnellere Variante.

Hab´s probiert. Beim zweiten Trennen der Platte ohne Abmeldung war der Fehler da. Dann habe ich die Platte am PC angeschlossen, die Systemdatei geklöscht und durch eine ältere Kopie, die ich zuvor auf einem anderen Verzeichnis angelegt hatte, ersetzt. Nachdem ich die Platte wieder am MyCloudMirror angeschlossen hatte, war ein Backup wieder möglich.

Geniale Lösung - dass da von WD niemand drauf gekommen ist!!! Schließlich hatte ich denen ja geschrieben, dass es letztlich an einer Systemdatei zu liegen scheint. Natürlich hatte ich mir es viel komplizierter vorgstellt, dass die aus nur ca. 20 Zeilen Text besteht, hatte ich nicht erwartet. Ich danke dir und drücke als nächstes den Button “accept as solution”.

Hoffentlich kannst du dein Problem, weshalb dein System immer wieder abstürzt, auch lösen!

<edit: siehe weiter unten>

Herzliche Grüße,

Wein-Franke

Mein Problem ist das gleiche und somit auch gelöst. :wink:

rl2664 wrote:> … und nebenbei festgestellt das ein längeres Kabel nicht mit der externen Platte harmoniert. Besser das originale Kabel verwenden, das aber nur nebenbei.

Ja das mit der Kabellänge kenne ich auch.

Das längste Anschluss Kabel, das ich für USB 3.0 zu kaufen gefunden habe, ist 1,8 m lang. Damit funktioniert meine Platte, die extern mit Strom versorgt wird. Mit einem 1,8 m USB 3.0-Verlängerungskabel zusätzlich zum Originalkabel funktionierte die zweite Platte, die den Saft nur über das USB-Kabel bezieht, aber dann überhaupt nicht mehr. USB 3.0 scheint da deutlich anspruchsvoller zu sein als 2.0. Dafür laufen die Backups aber auch wirklich flott.

Ich hab mir zwei 1 Meter Kabel gekauft. Ein billiges und eins teures. Mit dem teuren kein Problem, und das billige zickte auf einmal rum so das die Platte am PC nur noch klackte und erst gar nicht mehr anlief. Allerdings nur mit der HGST Touro, die WD Elements scheint da nicht so empfindlich. 

Ich habe das auch auch nur erwähnt um das Kabel als Fehlerquelle auszuschließen. Ich dachte das die My Cloud vielleicht aufgrund des Kabels die Verbindung zu der externe Platte verliert.