WD MyCloud is unbelievably unreliable!

I loved WD MyBookLive. Then I upgraded to MyCloud 3TB. It worked somehow. Not as reliable as MyBookLive. But for today it is rendered itself totally useless. It is just never there when needed. I hardly can access it through web browser - OK can, but this is a quest, a very slow quest that I success after power cut of the device usually.
How I use WD My Cloud is a very simple use case. And it fails most of times lately. I have it running as servers should do. It is connected to my home network through wifi router. I copy my files to it and I use access those files through my PS3 or PS4. It has worked for years, was most reliable way to watch my media when MyBookLive was around. But With MyCloud things went bad. And then worse. today the device is rendered itself more useless after every firmware update.
I just cannot understand how it is possible to ruin such an excellent device! It worked. Simple media server. Boot it up, copy a file and watch it through any DLNA device. It worked! Today it is barely accessible, always scanning content and useless.

1 Like

Hi, have you tried performing a system only factory restore on the drive? Have you turned off remote access? What version of the firmware do you have installed?

Hi, I have the latest firmware (Oct 2015 if I remember correctly). Remote access is turned on.
Haven’t tried system only factory restore yet. Is it sure that it does not affect my shares?

Right now I can access the drive only through smb://WDMTCLOUD in local network. I cannot see it through MyCloud app (no problem accessing MyBook Live). Right now it is not visible as DLNA service also. And also I cannot access its admin UI by http://deviceip/UI nor the Twonky server by http://deviceip:9000

In know after couple of restarts I probably get it working again. But it hardly stays stable lately. If I haven’t touched it for a week and then want to do simple things as watch a movie or pictures through Twonky server or copy some files to the drive the MyCloud is hardly there.

The point of a server should be stability. My old MyBook Live 2TB is perfectly stable, has worked as TimeMachine more than year without any assistance. My MyCloud 3TB wasn’t even able to finish first backup so I gave up and didn’t care.

But now the MyCloud fails doing two simple things as serving media and being there for copying some gigabytes of files without stuttering :frowning: I cannot tell exactly when or with what firmware my problems started. I was able to copy almost 2TB stuff on it and get media stream out of it many months. The stability just has got worse slowly step by step.

What OS is on the computer your using to access the My Cloud? And how is that computer connected to the local network, wirelessly or Ethernet? Can you test with another computer?

Note that Windows 10 users are having some issues seeing the My Cloud and there are known issues with El Capitan on the Mac. Both appear to be OS issues which are necessarily to be blamed on the My Cloud.

I have Yosemite and El Capitan over wireless.

Today I dug out my 12 year old WinXP laptop for testing. Drive share access is fastest with WinXP. Also copying from and to the drive seems to be rather stable with XP. It is very slow - more than 1.5 hrs for 700MB file but at least it was stable. Yosemite copy test still fails.

Accessing MyCloud UI (from any device) is very slow - refreshing login screen (and any screen) takes 50 seconds. It has always been notably slower than with MyBookLive but not as slow. Accessing Twonky server UI (port 9000) succeeded after 5 minutes.

I try to export settings and perform system only reset.
UPDATE: UI is not responsive, again :confused: Cannot even reset from UI
UPDATE: Connected Yosemite with ethernet. Average copy speed is 1.3 MB/s. Doesn’t look normal.

Have you tried a four second reset by holding in the reset button on t he back of the My Cloud for four seconds?

With respect to slow copying speeds, see the following link for more information:


There are a variety of causes that can generate a slow My Cloud. See the following link for more information:


1 Like

I tried now 4 second reset. The drive has rapid blinking blue. User manual does not state the meaning of this.
UPDATE: It finished successfully. UI just do not load. But files are accessible and dowload speed over wireless has improved a lot. Speed is 1 MB/s :smile:
UPDATE: got UI now, so far it feels normal. Thanks!

1 Like