WD MyCloud Gen2 - Enable apps install tab + Apps!

@Fox_exe just a little typo in the Debian install how to: you are referring to a file called rootfs-jessie.tar.xz but the filename in the repo is named jessie-rootfs.tar.gz, rather than this kernel upgrade to kernel-bin_4.15.0-rc6 and dist upgrade to stretch (Dev folder) seems worked flawlessy in ~1h but after the last reboot after dist-upgrade seems mycloud password is no longer accepted seems root account have no permission to access SSH and i’m locked out :confused:

Also the (unbrick) bootable USB seems not booting, probably i need to erase again the HDD from a PC to avoid Debian from booting…

Finally after, deataching HDD, booting recovery minios, reattaching HDD while powered on, and using the miniOS to mount debian root (was /dev/sdb3) and add my authorized_key i managed to login again.

PS. is normal that i still see old kernel with uname -r?
root@wdmc:/lib/modules# ls /lib/modules
root@wdmc:/lib/modules# uname -r

EDIT2: sorry going to use this post as my backlog
omv5 installation gone ok following Installation on Debian — openmediavault 6.x.y documentation just need to issue apt install postfix as it was searching for this package

also omv-extras OMV-Extras.org Plugin - Guides - openmediavault installed successfully with few plugins.

actually i’m locked on docker, installing from the OMV GUI started spamming “error” on the UI, looking at logs:

Apr 06 09:55:11 wdmc.fritz.box dockerd[14426]: time="2021-04-06T09:55:11.771765929+02:00" level=warning msg="Running iptables --wait -t nat -L -n failed with message: `iptables: Operation not supported.`, error: exit status 1"
Apr 06 09:55:12 wdmc.fritz.box dockerd[14426]: failed to start daemon: Error initializing network controller: error obtaining controller instance: failed to create NAT chain DOCKER: iptables failed: iptables -t nat -N DOCKER: ip

issued sudo update-alternatives --set iptables /usr/sbin/iptables-legacy as suggested around:

and actually i’m locked on

Apr 06 10:09:41 wdmc.fritz.box dockerd[16943]: time="2021-04-06T10:09:41.158961586+02:00" level=info msg="stopping event stream following graceful shutdown" error="<nil>" module=libcontainerd namespace=moby
Apr 06 10:09:41 wdmc.fritz.box dockerd[16943]: failed to start daemon: Error initializing network controller: error obtaining controller instance: failed to create NAT chain DOCKER: iptables failed: iptables --wait -t nat -N DOC
Apr 06 10:09:41 wdmc.fritz.box dockerd[16943]: Perhaps iptables or your kernel needs to be upgraded.
Apr 06 10:09:41 wdmc.fritz.box dockerd[16943]:  (exit status 3)

ok probably i found the culprit should be the missing iptable_nat module ( missing in 4.15.0-rc6 and also 4.15.0-plus, and this plus kernel totally killed my device so i’ll restart from the rescue mode…) probably i need to recompile the kernel but the last version is from 2016 :frowning:

Transmission tested and working!


I have updated it to OS5. Downloaded the plex from plex website directly(OS5) for My Cloud (Single Bay). I got it installed, but not configured yet. Does it work normally on OS5 without being able to repack the file?

it seems so. It’s currently updating my library since I had to add everything once again. It this works, there is no need for my updates anymore.
update 2
Everything seems to be working. I don’t understand at this point why would one not upgrade to OS5 when Plex is there?

On OS5, you don’t have the Php info and PhpMyAdmin yet at least.
Can’t find a way to “re-package” or understand how to do it.
Here are the working files on OS5 for Gen2

How can i use the repackager?
I don’t get the instructions, i use windows, and i can use SSH on a VPS i have.

But can OS3 apps be converted into working with OS5?
Or can OS5 apps for other models work with WD Gen2 Single on OS5?

Open your VPS or create one locally. You can use ubuntu64 with Virtualbox.

  1. connect to it and create folder plex and enter it
  2. download mksapkg-64b_1.3 and rename it to mksapkg-64b
  3. set a chmod to 777 to mksapkg-64b
  4. download the file test.sh and chmod it to 777 (just in case)
  5. go to plex website and download a file for OS3 and My Cloud EX2
  6. watch the video, it’s quite easy
  7. run the test.sh and wait for it to be done
  8. connect with ftp and download the file
  9. install it on your wdnas with OS3 using the methods from the first post

You can find the video file and everything else on https://wdnas.lampir.dev

So good people :slight_smile:

Thank you for the support these few years and I hope that I have helped a small number of people to have the latest version of plex. Since the new OS5 is supporting the plex out of the box, there is no need for me to repack the files anymore.

The link will still be active, but I will no repack them. You can use the archive and you can find the video I created on the website as well as the script for it.

Good luck with it :slight_smile:


What video?
(6. watch the video, it’s quite easy)
All i see are the files you mentioned and the instruction file.

Also will it work on Centos 8?

Go to the link.
Click on the folder plex.
Click on the file plex_install.mp4

I am using ubuntu, you can try, if not, it’s free to install ubuntu on a virtualbox and it takes minutes.

1 Like

Os 5.
No puedo acceder a web Plex http://ip:32400
alguien sabe como acceder a la web de plex???

I can’t access web Plex http: // ip: 32400
Does anyone know how to access the plex website ???

You use the IP address of the My Cloud followed by :32400/web

For example, if your My Cloud’s IP address is then to access the Plex Media Server on that My Cloud one would use

The IP address you are using (per your screen shot - is trying to access your local computer. The IP address is the localhost address / loop back address to the local device/computer. Use the IP address of the My Cloud instead. An explanation of the address: LifeWire: IP Address Explained


la aplicación no funciona WDMyCloud_plexmediaserver_11415488.bin
he instalado WDMyCloud_plexmediaserver_1.20.4.3517.bin

the application does not work WDMyCloud_plexmediaserver_11415488.bin
I have installed WDMyCloud_plexmediaserver_1.20.4.3517.bin

I’m using firmware 2.41.116. I’ve tried to paste the code on Home tab in the Javascript console and hit return, but there is an error:

Uncaught TypeError: Cannot read property ‘style’ of null
at :1:41

If I run it on Aps tab, the console respons with:


Please help.

first of all thank you to all of you providing the tools and hacks to have apps on My Cloud Single Bay Gen2.
Only with this the Device is really usable for me.

I hope someone can confirm my thoughts on OS5 update.
I am still on OS3 and want to update to OS5.

I am using Plex and Debian Chroot on my OS3.

With Debian Chroot i managed to use rsync and cronjobs to have a backup (similar to raid) solution to save my data to USB attached HDDs on the My Cloud. I have 4 HDDs in total.
I also use Debian Chroot to have some scripts running at startup preventing the internal archiving of the My Cloud, which made it slow and not deep sleeping.

If i got it correct with OS5 i can install Apps without tweaking in the development console of the browser?
Plex is supported out of the box? So no need to repack anymore?
Do i need to save my Plex database in any way before update? Or will it survive?
Will the Debian Chroot still exist or do i need to safe my scripts and set it up again?

Thanks again and best regards,

On update all apps will be removed, so make a backups.
Chrooted debian available on OS5. Just install app and replace chroot folder with old one.
Same for other apps.

For other thins - sorry, i don’t use it, so can’t answer.

Wow, thanks for the fast answer.
Thats perfect, i will save the chroot folder.
I will check if Plex also offers a backup.

Sounds great so i will update on the Weekend :wink:

Thanks a lot!

Ok, i updated to OS5.
But i have a problem with repacking Plex App.
I installed the provided OS5 Plex App.
There i could download the newest OS5 App as before in OS3.

Now i tried to repack this for MyCloud SingleBay.
The problem is that i can not get it extracted.

I use the same script as before with:
dd if=PlexMediaServer.bin of=PlexMediaServer.tar.gz bs=200 skip=1
tar -zxvf PlexMediaServer.tar.gz

But tar is telling:
gzip: stdin: not in gzip format

I compared the header of on older OS3 bin with the header of the new OS5 bin.
It is a but differnet:
OS3: KingsCaZplexmediaserver
OS5: GrandTeZplexmediaserver

Hope someone can help me here.

P.S: Found a solution now.
On Media Server Downloads | Plex Media Server for Windows, Mac, Linux, FreeBSD and More for OS5 you can download the bin file for single bay now. Thats perfect and so no need to repack.

But the question is still why is it not possible to unzipp OS5 Apps?


OS5 header 4-bytes longer.
dd if=PlexMediaServer.bin of=PlexMediaServer.tar.gz bs=204 skip=1

1 Like

Ok, perfect!
Thanks a lot!

The new method also followed with a similar error that’s experienced by @Stefmark. My error on firmware 2.41.116:

Uncaught TypeError: Cannot read property ‘style’ of null
at :1:41
Please help.