WD MyCloud Gen2 - Enable apps install tab + Apps!


#228

Thanks, mines a Gen1. So will this “Dirty Hack” work with Gen1?
If yes, can you explain from the beginning in a simple way what should I do?


#229

No.

Hence the thread title…


#230

But in the download links there is a folder called Gen1?


#231

And I want to install the 2.0 firmware to my gen1. When I manual update with the firmware file, will it work? Currently it’s v04.


#232

I don’t want to try it, because I have a lot of data in my cloud. I don’t want them to be gone. I searched for how to unbrick a My cloud, and it needs to be disassembled. I just need to be sure.


#233

You can’t install v2 firmware on a fen1 My Cloud. Different hardware.


#234

You CANNOT install the v2.x firmware on a v4.x single bay My Cloud. The 2nd gen v2.x single bay My Cloud has slightly different hardware than the 1st gen v3.x/v4.x single bay My Cloud.


#235

Because you traversed up the hierarchy of the fox_exe’s repository, into the Gen1 area; that’s not part of this app installation hack. Fox_exe has also done development work on the Gen1 devices. And the EX family.


#236

I succeded in apllying the steps including refreshing my cloud… The “Install an app manually” button appears but I am stucked at the Acceptance form when I click on it. The acceptance form is opening and the Accept button doesn’t respond in any way on click… Do you thnik you can help me with a solution for this, so that I can reach on installing PhpMyAdmin app?! Thanks in advance for your time!
PS: “Or maybe there is another way to install the phpmyadmin app directly from define.js file by modifying it in some way”


#237

Hi chrradu,

You can run the following on browser console to bypass the License acceptance form.

APPS_EULA=1; check_app_eula();

Click on the Install link again to select the file.


#238

Thanks for your answer… I managed to pass through this step too… The only problem I have now is that I can’t configure the MySql server with my admin user from the WD My CLoud: #1045 Cannot log in to the MySQL server. Any idea how to solve this one too?!


#239

Take a look at the following post

https://community.wd.com/t/setting-up-sql-db-how-to-get-phpmyadmin-working/97754


#240

Hello, someone have an update for Milestone Arcus Surveillance App? the version in the repos (2.5325088) wil not allow (anymore) to get free licenses redirecting to this info page

http://shop.wdc.com/store/wdus/html/pbPage.MilestoneSoftware_OldVersionPage/ThemeID.40263900?id=milestone&sid=

that basically ask to update the app


#241

Hi Fox, how you doing?

How do you get updated versions for the media server? I tried several times to update using the file downloaded for the website, but I found an error every time. Its`s just possible with your files, how do you get those files?

You modify the original files? Can you teach me how to do this?

Thank you in advance!


#242

How can we get to install the new version of plex ? I download manually the : WDMyCloudMirrorGen2_plexmediaserver_1924285-9f65b88ae
But it can’t install it !
Any ideas ?


#243

Need Debian or Ubuntu (Use LiveCD/USB for example)
Download this tool or get it from WD Sources.
Download Plex for WDMC Mirror (Or any other WDMC model)
Unpack in one folder and repack package for WDMC G2:

dd if=WDMyCloudMirror_plexmediaserver_1924285-9f65b88ae.bin of plex.tar.gz bs=200 skip=1 tar xvf plex.tar.gz cd plex ../mkapkg-x32 -E -s -m WDMyCloud


#244

I don’t have any of those could someone send a link for the latest update of plex please ?

Thanks !!
@Fox_Exe YOU ROCK !!!


#245

Hi Fox!!

When I try to run the last line I’m getting the error:

bash: /mkapkg: No such file or directory

What can be wrong?

I’m running a virtual machine with Ubuntu in the MacOS X High Sierra

Thank you!


#246

Did you follow this step (see fox’s post for the link to mkapkg)?

Did you run ../mkapkg or ../mkapkg-x32 ?


#247

Now I’m getting this:

parallels@ubuntu:/media/psf/Dropbox/Atualizar PLEX/plexmediaserver$ …/mkapkg-x32.dms WDMyCloud
ERROR: model_name not specify

Usage: mksapkg -E -s -m [model_name]

Supported model_name:
WDMyCloudEX4
WDMyCloudEX2
WDMyCloudMirror
WDMyCloud
WDMyCloudEX4100
WDMyCloudDL4100
WDMyCloudEX2100
WDMyCloudDL2100
WDMyCloudMirrorGen2
I’m not familiar with Ubuntu, maybe it’s a simple thing, I don’t know. How can I fix this? Thank you!