WD MyCloud Gen2 - Enable apps install tab + Apps!


#186
  1. Make sure you are running gen2 wd mycloud
  2. ssh to the mycloud and post output of

does this show link to define.js file you put in your public folder?

You are not getting option to add crack means you have not linked define.js to downloaded file.


#187

I just bought a 2tb My Cloud drive from Currys in the UK. They told me that Plex would work on it, but when I got home, I soon realised this was not true. Anyway, I found this crack and I have managed to get the install apps tab to come up. However, when I click the install new app link I’m asked to accept the terms. When I click accept nothing happens?
Any help would be great.


#188

If you are using firefox hit ctrl+shift+i , and paste below code in console

APPS_EULA=1 check_app_eula()

after this click on manual install link.


#189

I’ve got a notification from plex that there is an update.
And, the update file is “WDMyCloudEX2_plexmediaserver_1754035-313f93718.bin”
Is it OK to update WDMyCloud Gen2 with it?
If not, could you rebuild the Plex to the latest version?


#190

Someone have a solution to use Arcus?


#191

Thanks Jasuit. I’ve been having trouble to make my plex work with old versions, but with you version it works fine.


#192

Hi

This is exactly what I want, if I could just understand it. I don’t know how to connect to something via SSH and my lack of knowledge about it makes me worry that if I mess about with it I’ll brick my drive. Is there a good idiots guide that anyone knows of that will explain it nice an slowly for a plumb like me?

Does plex work on the single bay units, I found this thread from another where the suggestion was the single bay units weren’t up to the job.


#193

Hello Jassuit

The WDMyCloud_plexmediaserver_1553634.bin is working well - thanks a lot. But there is a new version 1754035
Would you mind share where can I have the famous WD app builder tool and whether it is a Windows or Linux tool.
Thank you in advance

Regards


#194

Hi, I am trying to package an app myself, but when installing, I always get this error message:
“Die App konnte nicht installiert werden” (german)
“Couldn’t install app” (translated)

This happens, when I am packing my own app using the mksapg-tool (mksapkg -E -s -m WDMyCloud).

But it also happens, when I try to repack an app like phpSysInfo (without any changes to scripts or rc-file). The original phpSysInfo just worked fine.

I have the WDMyCloud gen2 with most recent firmware.

Do you have any tips on how to solve this?


#195

Is there a tutorial for repacking the apps so we could do it ourselves instead bothering other people?


#196

Also very interested in running the latest PlexVersion on the MyCloud Gen2.

So is there is anyway to repack the apps ourselves, much appreciated!


#197

Yes please!

Also, for everyone stating that they can’t click “Accept” on the ToS popup, you need to downgrade your firmware.

Does anyone know the most recent firmware version that WILL work without breaking the TOS? I’m using 2.21.119 and I’d like to upgrade it as far as possible.


#199

I can confirm that downgrading, following this tutorial, and then updating the firmware works. I’m on the latest firmware and all of my apps were preserved.


#200

Only for test: WD Crack v1.1

Update for Plex: PlexMediaServer v1754035


#201

Hi @Fox_exe, I found a way to re-enable the “apps store”. Feel free to integrate in WDCrack if you want.
It’s a bit “ugly” but seems to work, involves the use of chattr command to set the file with the app index write-protected even for root, so the webui can’t mess up with it (in 2.30.165 it’s cleaned every time you refresh the web ui) and therefore preserve our custom list.
http://i.imgur.com/kHp5Gp9.png
For anyone to test:
Package: CustomAppList 0.5
source in github.
Install the custom list app manually, then click again in the apps tab so it will reload. You will see it stuck in “Loading”, click on the App Store button on the left (big blue one) and you should see now new apps to install :smiley: (only shows updated and not installed yet ones).

Salud.


#202

Is WD Crack v1.1 worked ok, @hashashin?
I had got Blue Led Blinking when use v1.0, so if v1.1 work well, i’ll try again!

Can anyone got my advice: i want use Plex Media Server and transfer file from PC to MyCloud, so i’ll installed which apps?


#203

Hi @philipvn, I don’t test 1.1 myself as I upgraded to 2.30.165 from an already parched system with the 1.0 (I don’t usually touch vital things that are already working). It was just coincidence that @Fox_exe was working on 1.1 and myself on restoring the app list, almost at the same time :open_mouth:. So sorry I can’t help.

About your other question I guess you should install Plex and you are good to go, as the device already does the file sharing/transfer thing: samba and/or nfs.

Salud.


#204

Thank your advice, @hashashin! i’ll try WD Crack 1.1 late.
In 1.0, when crack WD, i installed: Plex, Transmission, Utilities & Utilities extra
Then when it’s unnessary, i unstalled all of us, just keep Plex. When reboot MyCloud, it’s brick - Blue Blinking Led.

By anyway, ver 1.1 is installed as same way like 1.0?


#205

Yes.
But im not test it on real device (Im on Debian now).


#206

hi, thanks for your great work! I wonder if you know the default password for nbzget?
I tried nbzget & nbzget but it doesn’t work